cancel
Showing results for 
Search instead for 
Did you mean: 

Known Issue: Headset Says Memory Full, but it is not

Hi, my Oculus Quest 2 headset is saying low memory, but I have heaps of memory. It is making it so I can not play my game. What is causing this problem or does anyone have any solutions.

158 REPLIES 158

im still having the same problem as her. im also having problems where i cant link get into oculus app due to location options after downloading. any fix?

 

Hey there, @big.dawg.harlem. We can definitely understand how concerning it would be to run into the same memory, crashing, and slow update issues. We'd be glad to help out however we can! Could you provide some more details about the issues you're experiencing for us? We'll gladly look into troubleshooting to try out and do everything we can to get this resolved. We'll be looking forward to hearing back from you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey there, @big.dawg.harlem. We just wanted to check in since we haven't heard back from you yet. If you'd still like help with this just let us know, we'd be glad to help out!
 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Potato9030
Honored Guest

So I was trying to play VR chat right I see a interesting world and I made a PRIVATE server and I load in and then guess what happened it kicked me out before I could even load in and the error message said " you have been sent back to your home because your system ran out of memory" and i think that's weird because I HAVE 100 GIGABYTES WORTH OF STORAGE LEFT ON MY OCULUS and the funny partis that to download the room on my oculus it takes up 90 MEGABYTES NOT GIGABYTES MEGABYTES the same thing happens when I play like rec room or other multiplayer games but instead it says my wifi disconnected even though my wifi is perfectly fine. so like imagine this, Your playing some sort of social game right and your having fun and playing with your friends and then out of nowhere you disconnected because supposedly your wifi disconnected for no reason at all and guess what IT EVEN HAPPENS IN THE OCULUS MENU like you could be deciding what game to play and then out of nowhere against your wifi disconnects and then it happens over and over again until you finally decide to not play your oculus for the rest of the day and the next time you try to go on your oculus the same exact thing happens. So if anyone has a solution to this please tell me. (also I tried uninstalling VR chat and going into the exact same game and the same thing happened so oculus don't try to tell me to "uninstall my game and reinstall)

If you're having trouble playing VR games on your Oculus headset, like getting kicked out of games due to memory issues or Wi-Fi disconnections, try restarting your headset and router, checking your internet connection's stability, updating your headset's  software and router's firmware, ensuring there's no overheating, closing background apps, clearing app caches, and contacting Oculus Support if problems persist. Exploring community forums or Reddit for solutions might also help. If nothing works, seeking help from Oculus Support is recommended for more specific assistance.

hello I’ve had the same issues as the original comment as none of my apps will download/update due to “low memory” but I have visibly lots of storage left, I’ve tried the boot and factory reset but neither have worked, what should i do? After the factory reset when my apps needed to reinstall it became more of an issue 😞

Galaxitus
Honored Guest

From what I could gather, there seems to be an issue with the memory allocation of the download/update system app. For some reason the OS attributes too much memory (during the download/update of an app via the store/distribution) to the download/update system app and doesn't fully free up that reserved memory afterward.

Depending on what has been done before playing a game (which game(s) was installed and/or updated), the available memory will varies between users.

This can happen to anyone with any amount of remaining storage space because it's just got nothing to do with actual storage space. All you need to have a risk of it happening is having an app getting a relatively huge update or downloading a new app.

This is why restoring to factory settings doesn't actually help against the issue (and might even make it worse).

This problem seems to have sprout when META has changed the behavior of the app update system. (When the OS was updated which added a toggle to the shutdown/restart menu to updates apps before shutting down or restarting. By the way, that toggle is still bugged and will still try to update apps for hours even if everything is already up-to-date. This might have a link to the update/download problem... or not.)

At the moment, what you can do is shut down the Quest 2 for ~10 seconds after every updates/installation are done, then start it back up. This is the only way that seem to efficiently clean the reserved download cache anew.

A reminder to anyone who's reading this:

To shut down the Quest (and not put it in hibernation which doesn't clear the cache),

1) Unplug the headset from any power sources, if applicable. If it's plugged in a PC or on a power bank (external battery), unplug the USB wire from those power sources. (you don't have to unplug the USB plug on the headset itself, but just the one in the PC or power bank.)

(It's important to do 1) before 2), because for some reasons, the headset will immediately restart if it's plugged in a power source as it's supposed to be powering down.)

2) Hold the power button for a while until you hear the bee-hu sound and the menu to restart / shutdown appears. (For the moment) set the "Update App before shutdown" to OFF and then press "Shutdown".

3) Wait for 10-15 seconds.

4) Hold the power button for a while on the Quest 2 until the white light appears.
(If the headset is shut down, it won't power up just by tapping the power button. My guess is that this is to ensure the headset doesn't power on if in a bag or something and the button is suddenly tapped on. You got to hold the button for a shot while.)

5) Once the headset is powered on, if applicable, you can plug it back into a power source (PC or power bank).

(Why doing 4) before 5)? Because the Quest 2 can be finicky when it's charging while not being powered on. Some times, if I plug the headset in the power source, holding the power button only display the charging state of the headset, but doesn't power on it until a few tries.)

carnageblood123
Honored Guest

To be honest the oculus is a waste of money it always messes up and you can never play vr chat without it saying not enough memory to play I hate the oculus quest 2 meta fix your headset

 

Have you considered the possibility that the fact VRChat is trying to use more memory than is available on the headset (and the same amount is on every single Quest 2 in existence), might be down to VRChat, rather than the headset?

You are effectively saying "I want to use a car that is too wide for the roads. Fix your **bleep** roads".

Unfortunately, my "In to the Radius" is the same, it will start to stagger, freeze and then crash. Message is low memory, and then sends me back to my home page. I restart the game and then everything seems to work fine, but I can guarantee that after playing for a while longer,  it does the same.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?