Showing results for 
Search instead for 
Did you mean: 

Known Issue - Meta Device Code Not Working

Not applicable

Everytime I have tried to add another accounts onto my quest 2 the device code on says "Invalid Device Code Request! Please try again!" I have factory reset my headset and done all troubleshooting methods.


Accepted Solutions

Retired Support


Hey hey guys! Just reaching back out here to say there is something for us to give a shot. Could you please try the following:

  1. Double check that you're trying to set up your device with the same account that you're logged into on your app by going to
  2. You can go to on your mobile or desktop app and log out if you're on the wrong account
  3. Next, you can either log in with the correct account or you can also start over using different login info by factory resetting their headset. (This will wipe all data from the headset but not erase purchases from your account, so you will be able to redownload purchased apps upon completing setup.)

If this doesn't seem to help, please don't hesitate to create a support ticket with our team for some further options!

Genesis does what Nintendon't! Send me a DM if you have questions. I'm happy to help!

View solution in original post


Hi, I can't add a second account. I have tried on my two Quest 2 devices. I follow the correct steps and get to the screen that tells me to enter an 8 digit code on I am logged into the web page, I enter the code and the page returns with "Your device is connected." On the oculus there is a brief flash of a similar success result but that is immediately replaced with "an error occurred please try again." 


I've tried all of the things suggested by support and the forums:

- different browser

- different device

- delete oculus app

- reset/wipe Quest 2


One of the most frustrating elements of this has been my experience with Meta Support (my ticket has been active for over a month) which seems to toss random ill informed tasks (try a different browser, and today, record your experience with no details on what they want recorded or how). They also told me I can't return the device because I've had it for more than 30 days. But I've been working with them for more than 30 days while they tell me to be patient while they trouble shoot the problem. Help @MetaQuestSupport 

So, I live in the United States and been using quest 2 (64gb ) for about a year now !!! Just purchased a brand new QUEST 2  (128gb) for my brother who LIVES IN A DIFFERENT COUNTRY . I have a ton of games I purchased on my headset here in usa and I want him to be able to access those on his headset. How do I proceed . I tried following the steps listed .press the O button ,

hover over the clock ,

click on click , pull up quick settings ,

Click on accounts ,

APP SHARING IS enabled already ( I see it ) . 
( it says my account info and then primary under it ) .
I tried to click on add accounts. 

It says “ use this code to connect your headset 

it says remove headset , 

Go on web browser and type in ,( on mobile or desktop ) 

enter like a random 12 digit code ( mix of letters and numbers ) 

After I do that on my phone it saysERROR OCCURED , please try again .


so how do I add the my brothers account to my headset ???? 




Unfortunately, you can only share apps with accounts you’ve added on the device itself, that aren’t logged in elsewhere. You can’t log him into your headset and share apps to a different device. 

I go through the process of adding a second account but get stopped when adding the code from the headset to the website ( The website tells me I'm all set but the headset tells me there was an error. There's no options from there and I've repeated this several times with the same outcome. 

Hello, I cannot add a second a Meta account on my Meta Quest 2.


I know this has been asked a lot but here's an actual reproducible unique scenario.


I have a office-issued Meta Quest 2 and they gave me a Meta account to use with the Meta Quest 2. That meta account is a test user account of the office.


I created my own personal Meta account. I tried to add my personal account as second account but it fails after fulfilling all pairing steps in saying it was successful for a moment and then suddenly showing an error has occured, and the pairing didn't actually succeed.


I was curious, I factory reset the device and added my personal account first, which it succeeded, and then added the office Meta Test User account as second account, and this succeeded as well. However, office policy is to keep the 1st account as the office account. So I have to revert this.


TLDR; if first account is a Meta Test User account, adding a real Meta account as second account fails. Why is this? Is this a bug? Is this by design?

Hey hey! I'm impressed that you did some really good troubleshooting on your own for this to figure out what might be going on! I've got some more info on this that might help.


As far as secondary/additional accounts are concerned, you are unable to pair the headset with them. You can only actually pair the headset with the admin account. You should be able to add an additional account without issue, but you won't be able to pair the headset with that account to your app or anything. That could be why you were getting the error when trying to pair on with the secondary account. You should still be able to add that secondary account without pairing it.


Since you had success when reversing the accounts to where yours was the admin, have you tried switching it back again to see if you can get the accounts both on there with yours as the secondary? Sometimes there are weird little bugs that a factory reset can help fix, and that could be something that happened here.

Make sure you smash that Kudos button!

Heyo @jangelo0008! That seems like quite the pickle you seem to be in. I'd love to try and help out. 


To get a bit more of an insight to your issue, I do have some questions:


  • Does the device ask to input the code right away when adding the secondary account?
  • What error message do you get when adding the code?
  • Are you trying to pair the second account with a different phone/mobile device on the Meta Quest app?
    • If so, I do want to share that secondary accounts aren't able to pair to the Meta Quest app. They'd need to be the admin account on the headset. 


Hope to hear soon! 🤗

I believe I'm replying to you here. 


Thanks for the response. When I try this I am in the original account I've set up, I believe it is labeled as an admin account. Once I select to add a new account it tells me to go to the website and hand the headset over. It reloads the headset in the initial "bubbles" environment. From there it shows me a code to enter at the site. The message simply says that an error occurred, no number or letter codes to identify what the actual error is though. That was all I had tried up to that point, so I assume it was trying to use the same number/email on the account. I then tried to find a way to create a new account, thinking that may be what it's looking for, I was unsuccessful as it would automatically go to the account I have already set up. I guess in my mind I should be able to have my initial account and be able to simply create additional profiles, something like what I've done for my Playstation. One other thing, it does quickly flash another message before it give the error. So it goes, (from headset) add account > (from headset) it shows me the code to enter  > entercode at website > (from headset) a brief flash of a message (I think I've made out a checkmark with whatever the message is in that flash) > then message on the headset that an error has occurred. The website, however, does say it was successful. Hope that gives an understandable account of things as they occurred. 


Thanks again!

Hmm, alright. You're correct on the process that should be going, where you'd essentially just be adding profiles to the headset so this is a bit strange. 


Have you tried to reboot and power cycle the headset already?


  • Power cycle by holding the power button for roughly 30-45 seconds.
  • Reboot:
    • Turn off the headset.
    • Hold the Power and Volume Down(-) buttons together until the menu loads. 
    • Use the Volume Buttons to highlight Boot Device and press the Power Button.


If that doesn't seem to help out, you may want to make a support ticket with the team. They'd be able to best help out in this situation most likely.