Showing results for 
Search instead for 
Did you mean: 

Known Issue - Quest Link cable connection to PCVR doesn't work after v57 update


I am sick of this happening every time the devs roll out a new update.

Oculus app updated this evening, Quest Pro headset will no longer be detected via cable connection, only wireless.

Doesn't matter if I'm opted into PTR, or opt out and uninstall the new drivers that came along with this.

If anyone manages to get themselves out of this situation lemme know how ya did it!

313 REPLIES 313

It works for me



Soooo....This worked for least for one night so far.....

Support had me reset the quest 2 to factory settings. Now, some einstein had the idea that I need to pair my quest 2 to my phone to complete setup. What a joke that was as before I factory reset the headset I could see the headset on my galaxy S22+'s bluetooth, after the factory reset I could not see it. I got mad, grabbed my wife's phone and put the quest app on there. Got the headset to pair, and was able to finish setup. (If I can connect helmet to internet during setup, why do I need to pair it to a phone??? Really???) Anyways, When the headset got to it's desktop it prompted to accept or deny the USB connection and I hit accept. I launched the oculus app on the PC and was able to see the desktop again after telling the headset to connect. I left it connected to use it last night. It didn't disconnect thankfully! IDK if it will connect again but I am not factory resetting this thing every time I use it. And for any developer that wants to claim it's my system, here's my specs:

CPU: Ryzen 9 5900X, M/B= MSI Mag 550 Tomahawk with latest BIOS (NO USB ISSUES HERE), 64GB DDR4 RAM, 1x 500GB M.2 SSD, 1x 2TB M.2 SSD, 1x 500GB SSD, 1x 6TB HDD, MSI RTX 3090 Gaming 24G, OS=Windows 10 x64.

Yes but I couldnt connect to phone with bluetooth to finish setup, had to use my wife's phone to do so. It worked as I was back on DCS last night, IDK about today though.

Honored Guest


I feel it gets better if you re-enable the prompt when USB is connected, and selecting ALLOW instead of DENY file access...   (it was deemed the best practice to Deny and not prompt again, but when I Allow file access, usually I am able to establish Link, where-as when I Deny file access, Link is not established.

Try it!   And Meta , please FIX this (and the battery drain when Link cable remains connected to a turned off pc).

Heroic Explorer

META: You have disabled countless PCVR rigs with your update. This is taking too long already. A fix should have been issued already.

I am angry, just in case you think this will go away by itself.

You are making sure that the Quest platform for PCVR will not be taken seriously, ever. Who in their right minds would invest in a Quest and a good PCVR computer if all it takes is a stupid update from you guys to turn everything into expensive paperweights?

Are you going to reimburse me for my Oculus Ryft game library? I have a lot invested, and I can't play anything right now.

AND NO, expecting your users to turn on dev mode is NOT A FIX.

I am a software engineer by trade, with 30 years experience, and I would NEVER expect my users to "turn on dev mode".

This is ridiculous. Pay me back for my library then.

Intel i7-7700K, 32GB RAM - nVidia GTX 1070 Amp Edition 8GB GDDR5. Link Cable.

I would give you more than one kudo if I could.👏

That is so much how I feel.

 I agree. They should have rolled back updates to last known working update. IDK who the genius is that masterminds this kind of stuff but it seems every company has one. That one person who makes things way more difficult than they need to be. I did try my VR with PC link this morning and yes it did work but I shouldn't have to do a full factory reset on the device to wipe everything out. Furthermore I wouldn't require a setup needing to connect to a phone by bluetooth to continue setup. At most, just connect to your network and then have it direct to login through a browser or something and enter some code just like apps on the TV do. I was so P'd off that this link stuff happened then even more P'd off when I couldn't complete setup after a factory reset because I had to connect my phone to the headset. Luckily my wifes phone was able to connect. There's not even a phone number to call you have to do it through email or chat, etc.......that's complete BS too. You know how irritating it is for someone wearing glasses chatting with support and having to take glasses off, put headset on to do what support tells you, then take it off to put glasses back on and type???? I could just make a phone call and listen to someone while doing what they say...but noooo, that would make sense. Oculus or facebook or whomever is either too poor or too cheap (or both) to afford customer service reps that use a phone.


So I got bitten by this too. Difference is, in my case AIRLINK wouldn't work either. I got the LINK CABLE working with the Dev Mode workaround (it works but is really unstable!). But I cannot get Airlink to work at all.  I reinstalled the Oculus software on PC to no avail. When I go to AIR LINK in the Headset, it SHOWS the PC as usual, but is shown as DISCONNECTED and there is no way to try to re-pair (no pun intended) in case that is necessary.  I have NOT yet done a Factory Reset on the headset, as I am hoping for a hotfix soon, but I find it odd that I am one of the few with AIRLINK issues in addition to the USB issues with the Cable.

Any ideas?

By the way, it is NOT a network issue.  I checked and double checked everything and rebooted the router. When I use BIGSCREEN BETA with their Virtual Desktop, I connect INSTANTLY to my PC wirelessly.  Everything was working perfectly Thursday night, but after the update sometime Friday, I think,  it all went bad.

@Recluse205  Maybe try opting into the oculus desktop app public beta (settings/ beta tab.  Only takes a couple of minutes to do and doesn’t change anything.  It may ask you to update your drivers.  Just say yes.  Good luck mate and cheers.

i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 5200 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro w/Air Link, Vive Pro