Showing results for 
Search instead for 
Did you mean: 

Known Issue - Quest Link cable connection to PCVR doesn't work after v57 update


I am sick of this happening every time the devs roll out a new update.

Oculus app updated this evening, Quest Pro headset will no longer be detected via cable connection, only wireless.

Doesn't matter if I'm opted into PTR, or opt out and uninstall the new drivers that came along with this.

If anyone manages to get themselves out of this situation lemme know how ya did it!

314 REPLIES 314



Yep.. that was actually the first thing I did even before Developer mode.  It downloaded some drivers (I THINK) but still didn't work. Then I uninstalled and reinstalled the software, so the Public Test Channel is off by default now.  I'll try turning it on again in a bit. Hopefully they push a hot fix to the test channel. I did, however see something in this or another thread that said to expect some unreliability with LINK in the PTC and to turn it off if you used LINK. So.... it's a crapshoot.

Honored Guest

I'm so done with this. Is not possible that is already the third week in a row that I have to delay or skip the weekly meeting I have on vrchat with some friends. It never gave me problems, now week after week with these updates the cable link never works. Tried already everything, every solution. Nothing. Cable not detected, device not detected. This need to be fixed by the dev team, not from us that need to reinstall everything 5 times in a row and enabling options with a certain combination to not get f***ed. Hope their b+lls implodes. I'm so done with this s.

Can confirm, enabled developer mode and it instantly detected my headset and started working.

Any updates you can give us? Don't suppose there's a hotfix incoming?

So I managed to get it back.  Combo of things, including DEV MODE, PTC, mulitple re-installs of PC software, but eventually I managed to get back to SETUP where I got the option to PAIR the HeadSet with the Airlinked computer. THEN it connected. On V57 now and so far it, along with all the other stuff has my LINK and AIRLINK working (for now)

Honored Guest

This is still not fixed? Wow.

RTX 4070 | i5 12600K | 32GB 3200 | Z690

So this is happening to everyone else too. I thought my link cable finally died, as ive used it a lot, but apparently it is a software issue. Thanks for saying this so i would know that

Any solution so far ? my project is at stake 😞

Honored Guest

mi accodo anche io all'elenco delle persone che non riescono più a connettere quest2 al PC con cavo air link

ho passato il week end a cercare soluzioni provando di tutto e solo ora mi accorgo che il problema non è il mio PC guasto o il mio visore, ma molti altri hanno lo stesso problema dopo gli aggiornamenti

e' inaccettabile questa situazione, abbiamo speso tutti dei soldi per acquisto del visore e in molti casi fatti adattamenti sui relativi PC per aver prestazioni adeguate, ma spesso anzi troppo spesso, quando si ha del tempo per usarlo ci si ritrova immerso in problemi di malfunzionamento.

Quindi ora non so cosa fare, proverò a portare PC in assistenza, nella speranza che i tecnici sappiano fare di meglio di quel che posso fare io... tra l'altro a me non appare più la dicitura di accettare la condivisione dati... oltre al fatto che nelle prove ho provato a 'eliminare' il visore, quindi ora dovrei riattivarlo ma assolutamente non riconosce ne visore ne porta usb

mentre sull'applicazione cellulare funziona...

assurdo....semplicemente assurdo...ogni tre per due arriva un aggiornamento e distrugge il lavoro di set up fatto con fatica, oltre che a non permetterne l'uso.. passerò al triplo monitor o ad un ultra wide e abbandonerò il quest2

sono arrabbiatissimo con Meta...............


thanks for reply . FYi question asked 

Are you getting any error messages when connecting the link cable? If so, can you send us a copy?

Has this worked before?

Did you get any updates to any of your devices recently?

No both laptop and oculus is upto date 50065460051500330  os version sq3a.220305.009.a1

What troubleshooting have you done so we don't repeat anything?