Showing results for 
Search instead for 
Did you mean: 

Known Issue - Quest Link cable connection to PCVR doesn't work after v57 update


I am sick of this happening every time the devs roll out a new update.

Oculus app updated this evening, Quest Pro headset will no longer be detected via cable connection, only wireless.

Doesn't matter if I'm opted into PTR, or opt out and uninstall the new drivers that came along with this.

If anyone manages to get themselves out of this situation lemme know how ya did it!

313 REPLIES 313

What and where is the PTC? im having the exact same problem.. So PO.  hoping this fixes the problem



never mind its the PublicTestChannel

Did it manage to work? If so then perfect cuz it worked for me!

I have the same problem but with my quest 1 

it worked thank you the software recognizes the quest 1 again 

It did indeed! Take note Oculus. 

Yes! Getting the v57 build via PTC solved the issue. Seems like rolling back the v56 update would be a smart idea!



The Quest Link will not connect to my Oculus Quest 2. I've had the device approximately 2 years and I've had connection issues before. I've used two different cables and I recently switched back to the original which was working perfectly for about 4 months. If I ran into any issues I could restart the headset, or restart the Oculus service and it would solve it. Now it's completely dead. I've gone through all of the standard troubleshooting referenced on the forums, checked my USB settings, repaired the Oculus app, tried different USB ports etc. and nothing. I'm pretty fed up with this product at this point and I'm starting to think it's actually the jack on the headset itself.  

Edit: It's definitely the jack. The green light won't come on when I plug it in to charge.