cancel
Showing results for 
Search instead for 
Did you mean: 

Known Issue - Refurbished Quest replacement unable to connect controllers

N-Barbecue
Level 4

I just recently sent my quest 2 and controllers back to be replaced but the refurbished quest 2 controllers that was sent to me won't connect to the refurbished quest 2 headset that was sent to me so my headset is stuck in the paring initial setup screen. I tried linking my headset to my app to set up controllers that way but no matter how many times I tried to pair it putting the pair code in it won't pair up. I have factory reset several times. I have reinstalled the app already a few times. Yes my location and bluetooth is on. I have already been through setting this up with my old quest 2 that I sent back with no problems. I don't understand how I was sent a refurbished quest 2 and controllers that can not even set up. Please help me fix this or let me get a replacement that works.

157 REPLIES 157

Support told me yesterday that this issue is due to changes to allow meta accounts without needing a Facebook account. 

I don’t see why that would stop you at the controller pairing screen, though. 

I have asked for a callback next week for update. 

Well, support sent me an email with steps to try.

 

It worked for me as it updates the software to a point that lets the phone app complete setup and you can pair controllers from the app that gets you past the pairing screen in headset. 

So, if you have a PC, here are the steps:

 

  • Download the latest firmware file from: https://drive.google.com/file/d/1-XwU2uFh1O2MytV2w_kjhrBvoavq6kRy/view (perhaps you could make this available through official means more easily)
  • Rename it "update" and ensure that the extension ".zip" remains intact
  • Power off your Quest 2
  • Hold volume "-" and power until the device boots into a bootloader screen
  • Using the Volume buttons, navigate to "Sideload Update" and then press power
  • Connect your Q2 to your PC via the USB-C cable
  • Download the Android Debug Bridge (adb) "SDK Platform Tools" from: https://developer.android.com/studio/releases/platform-tools
  • Extract all to a suitable folder
  • Move the previously downloaded and renamed firmware file into the newly created folder "platform-tools" containing all adb files
  • In this same folder containing adb files and "update.zip" press "shift + right click" to open a command prompt (or powershell) window within the folder
  • Type "adb devices" and press "enter". You should see something like: List of devices attached: 1WHXXXXXXXX sideload     (note: 1WHXXXXXXXX represents your headset's serial number) I had to type ./adb for the commands to work. I was told this on pc  when I just used adp without the ./
  • Type "adb sideload update.zip" and press "enter" I had to use ./adb
  • After a few minutes the file will have transferred and your Q2 will begin updating
  • Once updated, you should be able to pair the app with the handset in the usual manner

Working, you're a star!

But **bleep** Meta for not communicating/solves this.

can you do this with a Mac ?

 

I did, same steps and you download mac-version of platform-tools.

need some help how to do it cause im on the command part and its not working

 

Do you mean “adb sideload update.zip”? 
What happens, not starting to upload or error message or what? 

yeah

the .\adb works but everything else wont

 

it says "the command adb was not found, but does exist in the current location. Window powershell does not load commands from the current location by default. if you trust this command, instead type: ".\adb". see "get-help about_command_precedence" for more details"