cancel
Showing results for 
Search instead for 
Did you mean: 

Known Issue - Refurbished Quest replacement unable to connect controllers

N-Barbecue
Level 4

I just recently sent my quest 2 and controllers back to be replaced but the refurbished quest 2 controllers that was sent to me won't connect to the refurbished quest 2 headset that was sent to me so my headset is stuck in the paring initial setup screen. I tried linking my headset to my app to set up controllers that way but no matter how many times I tried to pair it putting the pair code in it won't pair up. I have factory reset several times. I have reinstalled the app already a few times. Yes my location and bluetooth is on. I have already been through setting this up with my old quest 2 that I sent back with no problems. I don't understand how I was sent a refurbished quest 2 and controllers that can not even set up. Please help me fix this or let me get a replacement that works.

157 REPLIES 157

Spotlight is the name of the little magnifying glass icon in the upper right corner area of your Mac screen.  Just type Terminal in the Spotlight Search bar, and it’ll pop right up.

I took the original instructions from xShadeaux and added the info for Mac users.  If you take your time and do everything step by step, you should be good. 

 

QUEST FIX INSTRUCTIONS FOR MAC (revised from original xShadeaux post)

 

1.) Download the latest firmware file from: https://drive.google.com/file/d/1-XwU2uFh1O2MytV2w_kjhrBvoavq6kRy/view

 

2.) Rename the file "update" and ensure that the extension ".zip" remains intact

 

3.) Power off your Quest 2

 

4.) Hold volume "-" and Power buttons at the same time until the device boots into a bootloader screen

 

5.) Using the Volume buttons, navigate to "Sideload Update" and then press Power

 

6.) Connect your Q2 to your PC via the USB-C cable

 

7.) Download the Android Debug Bridge (adb) "SDK Platform Tools" for Mac from: https://developer.android.com/studio/releases/platform-tools which will create a new folder called “platform-tools”

 

8.) Move the previously downloaded and renamed firmware file “update.zip” into the newly created folder "platform-tools" containing all adb files

 

9.) Install Powershell for Mac (from the Direct Download): https://learn.microsoft.com/en-us/powershell/scripting/install/installing-powershell-on-macos?view=p...

 

10.) You will now need to launch Terminal from the “platform-tools” folder and run PowerShell from within Terminal.  This link will show you how to launch Terminal from a folder: https://www.maketecheasier.com/launch-terminal-current-folder-mac/

 

11.) Once you have launched Terminal from the “platform-tools” folder, you will then run Powershell inside of Terminal by executing the pwsh command.  You simply type pwsh then hit the enter/return button on your Mac, and now you should be running Powershell inside of Terminal

 

12.) Next, type ./adb devices and press the enter/return button on your Mac. You should see something like: List of devices attached: 1WHXXXXXXXX sideload     (note: 1WHXXXXXXXX represents your headset's serial number)

 

13.) Type ./adb sideload update.zip and press the enter/return button

 

14.) After a few minutes, the file will have transferred and your Quest will begin updating

 

15.) Once updated, you should be able to pair the app with the handset in the usual manner

yeetusboy69
Level 2

I just got my replacement today and am having the same issue! I do not own a PC to do the sideload. I guess I am going to have to pay someone to do it for me which is total BS!!!!!

Super annoying getting on here and seeing so many people with this issue and they are obviously still sending out these defective refurbished headsets!!!!

Hello djwolfd, 

So, I am trying this tonight and I am on the first step, After I download the file, it strangely loses the word ".zip." at the end. Just doesn't show up. So of course I was able to rename it but had to add ".zip."  Isn't the file supposed to download with ".zip" already there?

You may have your system set to not show extensions.

 

https://www.howtogeek.com/205086/beginner-how-to-make-windows-show-file-extensions/

 

This assumes you are using windows. If using a mac, I am not sure. 

 

First off, thank you for responding. If what you say is the case, then will the file work now that I have renamed it with a ".zip" ending?

 

I am on a Mac. Not windows. But I can see this is beyond me. I think I will have to bite the bullet and buy a new one from Best Buy (not Amazon) and get an extended warranty.  I am documenting everything and sending it to the NY Attorney General and any news organization that will listen, 

I just googled "show file extensions for Mac" and sure enough there is a way to do it. So I am pressing ahead!

I would delete the file you renamed and download again. You shouldn’t have to add the .zip

 

i am just worried you have a file named update.zip.zip

I HAVE SOME AMAZING NEWS!  Just by connecting my headset to my Mac Computer, I was able to get the **bleep** thing working again. I kid you not.  I connected the headset to my computer. Took out my Oculus app, I removed the batteries from the controllers (not sure this made a difference) and put them back in. The Oculus recognized the headset and did not ask me to "upgrade." Then, it gave me instructions for activating the controllers. Went through the protocols and now my headset works. The headset is even updating itself.  I an in shock. I would not have connected the headset if it were not for all instructions if not for all of you sharing instructions, But really. Could it just be this easy!?