Showing results for 
Search instead for 
Did you mean: 

Known Issue - Refurbished Quest replacement unable to connect controllers

Level 4

I just recently sent my quest 2 and controllers back to be replaced but the refurbished quest 2 controllers that was sent to me won't connect to the refurbished quest 2 headset that was sent to me so my headset is stuck in the paring initial setup screen. I tried linking my headset to my app to set up controllers that way but no matter how many times I tried to pair it putting the pair code in it won't pair up. I have factory reset several times. I have reinstalled the app already a few times. Yes my location and bluetooth is on. I have already been through setting this up with my old quest 2 that I sent back with no problems. I don't understand how I was sent a refurbished quest 2 and controllers that can not even set up. Please help me fix this or let me get a replacement that works.

157 REPLIES 157

All I had to do was connect my headset to my computer!  Then I took out iPhone, connected the Oculus app and everything went smooth from their. I did have the zip file on my desktop. And I did put it into that other file, but what do you think? It's crazy that this worked!

You were right, of course. I did delete it. I did download it again after telling mac to show the extension. But get this: I connected my headset and I don't think it was even in "Side load" mode. And I thought I should just see if the Oculus app will behave differently. Well I am in shock. Because the app did all the right things, next think I know the headset is taking me through all the steps to connect the controllers. As of now, everything is loaded as before and I'm totally back in business.  I don't understand it. I did not complete the steps with files. 

I'm just so happy to be back and I wouldn't have without you and this site helping me. You have no idea how happy I an right now. 


If you can, connect your headset to your computer via a cable.  Then, open your Oculus app and see how it goes. I did this tonight and it worked. To be fair, I had that Zip file everyone recommends on my desktop but I didn't do the steps after that. 

Give it a try. Let me know if it works. 


I just got mine to work and I suggest you try what I did. Connect your headset to your computer. Then take out your Oculus app and see if it recognizes the headset number and starts to connect and work. Just this simple thing got it working. Hope it works for you. 


Great news!  Congrats! 

Thank you! Thank you for working with me on this. You help me not give up 

Thank you, thank you, thank you, thank you! 

I want in...

Its been a month and still nothing 😧


This worked for me, maybe it will work for you. Connect your headset to your computer. Take the batteries out of the controllers. Open the Oculus app on your iPhone or Smart Phone. See if the app can "read" your headset number. If it can, you are in business. Or could be. Put the batteries back in your controller. See if it gives you the next steps. Let me know if you will try this and if it works. 

Good luck. 

no way 😄 thz so much