cancel
Showing results for 
Search instead for 
Did you mean: 

Known Issue - Refurbished Quest replacement unable to connect controllers

N-Barbecue
Level 4

I just recently sent my quest 2 and controllers back to be replaced but the refurbished quest 2 controllers that was sent to me won't connect to the refurbished quest 2 headset that was sent to me so my headset is stuck in the paring initial setup screen. I tried linking my headset to my app to set up controllers that way but no matter how many times I tried to pair it putting the pair code in it won't pair up. I have factory reset several times. I have reinstalled the app already a few times. Yes my location and bluetooth is on. I have already been through setting this up with my old quest 2 that I sent back with no problems. I don't understand how I was sent a refurbished quest 2 and controllers that can not even set up. Please help me fix this or let me get a replacement that works.

157 REPLIES 157

It would be nice for them to come up with a fix for those of us that don't have a PC. I have been told they are working on a fox gor 2 months now!

j’ai axactement le problème que mentionné ! Problème cela fait 3 ans que j’ai oculus 2 et maintenant j’ai tout perdu des achats fait ultérieurement 

TheAntiSocializer
Meta Quest Support
Meta Quest Support

Hey hey! Just wanted to update this thread with this solution since it seems we may have forgot to post it in here.

 

For anyone having this issue, please try the following:

 

  1. Open the Meta Quest app on your iOS or Android device. Wait about a minute while a background update is automatically applied.
  2. Close the Meta Quest app.
  3. Factory reset your headset.
  4. Try to pair your controllers and headset as new.

 

If that doesn't work, we suggest hitting up the team with a support ticket

 

Thank you! 

geofftanner
Level 3

This company sucks big time! My Quest 2 stopped pairing. They admitted it was a software problem that their engineers were working on. They asked me to send it to them. Their website says a replacement will be shipped between 3-5 days. 2 months and 50 emails later I still have no replacement. All they do is apologise. A serious waste of time and money. 

Count me in. I live in Sydney, Australia. I’ve been waiting 2 months for a replacement Quest 2. All I get from Meta Support are apologies and congratulations for being so patient! Sucks.

Here in europe i had more luck, send in my defected headset and they returned a working refurb headset in one week.The headset i had send in to prague , and got one back from ierland...

omikins91
Level 2

I wanted to come in here and update you guys my solution! In case people still have this issue, what i did goes as follows. Make sure you have battery on your controllers, I was having all these issues as described until I realized my controllers were low battery. Then go into the oculus app, if it connected the headset automatically,good, now it’s time to connect the controllers manually by going to “controllers” under “devices”. Unpair the last controllers and pair them again. This worked for me guys! I got rid of the pairing screen and let me choose languages and set up soon after. Good luck!

RoastPork
Meta Quest Support
Meta Quest Support

Thanks for sharing your perspective! Let us know if this works for anyone else!

Now you're playing with power...SUPER power!