Showing results for 
Search instead for 
Did you mean: 

Known Issue - Refurbished Quest replacement unable to connect controllers

Level 4

I just recently sent my quest 2 and controllers back to be replaced but the refurbished quest 2 controllers that was sent to me won't connect to the refurbished quest 2 headset that was sent to me so my headset is stuck in the paring initial setup screen. I tried linking my headset to my app to set up controllers that way but no matter how many times I tried to pair it putting the pair code in it won't pair up. I have factory reset several times. I have reinstalled the app already a few times. Yes my location and bluetooth is on. I have already been through setting this up with my old quest 2 that I sent back with no problems. I don't understand how I was sent a refurbished quest 2 and controllers that can not even set up. Please help me fix this or let me get a replacement that works.

157 REPLIES 157

Level 4

ok know im confused what the hell is happening oculus why is my devices in my account but not working HUHHHHHHHHH

Retired Support
Hey Guys! Thank you so much for bringing this to our attention. We see you guys have found a few potential workarounds in the thread, so we have raised this up to our engineering teams to take a look. Please keep using this thread to comment on what you are seeing and what has worked for you, and we'll be in touch as soon as we have some official answers for you guys.

Meta Quest Support
Meta Quest Support

Hey folks, thanks for raising this to the team! With having seen this before, we're going to take a look and see if there might be a bigger issue at work here. It looks like a few people have reported some things that have worked for them, but as always, please be sure to attempt any unofficial workarounds with caution, and avoid any that break our Terms of Use! Please keep sharing what you are seeing on this thread and we will share any updates we get here when we have them. Thanks everyone! 

*Accept as Solution button- If a post answers your question please let us and others know by hitting this button.
*Known issues - Interacting with our known issues threads helps us track how many users are also experiencing that issue. Definitely interact with those posts if you are affected!
*Kudos button - Give others a virtual High-Five for helpful posts and replies you agree with!

Please only DM a mod if we've asked you too, or in the case of highly sensitive content. General questions/issues/topics are best shared on the forum where others can take part/benefit from the responses/solutions/workarounds

Just to reiterate, the steps I posted came directly from Oculus support.


Support ticket #5464752, if you want to check. 


I think that’s about as official as it gets. 

I followed everything but I am on a Mac. I get all the way to the ./adb side load and then it says Total xfer: 0.00x which then it boots the oculus in the regular startup mode. Any idea on what else to do?

Type .\adb devices and it will identify your wired headset. 

I got hung up on that step myself. Once I figured out you needed the whole statement it was pretty easy.

Follow the directions but anywhere it states "adb" put ".\adb" and the rest of the command statement.    

I got it to do that and see where on the oculus it says upload but as soon as it says uploading it just makes the screen black and a few moments later it boots up in regular mode and still get the need update error when trying to connect. I typed in ./adb sideline and the other ways you said. It goes to upload but then says the transfer is 0.00. 

Maybe the got corrupted? I’d try redownloading it and see if it changes behavior. 

Level 4

Again I couldn't get it to work myself till I took it to a friend that runs a repair service to get it working for me. I'm sorry I'm not pc tech skilled so I can walk you through it and I'm not sure if I'm allowed to post he's business info here without getting into trouble by oculus support or I would.

Level 6

If anyone's still having issues, I made a post that's gained a LOT of traction. On said post, I made a lengthy tutorial which fixed my Quest-1 and allowed me to pair my headset. It should work for Quest 2 as well. In theory it should also indirectly allow you to fix/pair your controllers aswell. 


You can find the fix in question in one of the "Accepted Replies", or just in the reply section if you can't find it. Feel free to check it out here: