Showing results for 
Search instead for 
Did you mean: 

Left controller not powering after replacing battery

Honored Guest

So I recently ran out of power on both controllers, and so and got some sunbeam brand batteries, and they worked fine, and they drained fairly quickly so I went and got Duracells, and the right controllers LED turns on, but not for the left controller and I don't know why. 


Community Manager
Community Manager

Hey there therockinist, thanks for reaching out. We see that you changed your batteries in your controllers and no one of them is no longer turning on and has no LED light. 


First, try switching the batteries in the controller to see if the issue could be a dead/faulty battery. 

If this does not work, try leaving the batteries outside of the controller for 2-3 minutes before inserting them again. This will force the controller to do a soft reset and the controller (If it is working) will perform any updates it could have missed. 


Please let us know if either of these troubleshooting steps worked for you. If they did not you can send us a DM here on the Forums. if you'd like to do so, please click here or on our name to get to our profile page, then click "Send a Message" to privately contact us. Please remember, you must be signed into the community first to send us a private message.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honored Guest

The same exact situation just happened to me. It's as if the controller is locked except for Sunbeam batteries. How did you resolve this?