Showing results for 
Search instead for 
Did you mean: 

Left controller update in progress error message

Level 2

During my initial set up in oculus quest 2, a software update started and the left controller update was initiated but got stuck at 26% . It’s been more than 2 hours and I have tried everything from decoupling the left controller, removing and reinstalling batteries but the error message won’t go away. It lets me continue with the set up but the annoying message is there on the face ruining the whole experience 


Community Manager
Community Manager

Hiya AntuAvi! We see you have a stuck message and we get how disruptive to gameplay that can be! 


Ready player 1? Start by performing a hard reboot, you can do this by depressing the power button for 30 seconds. If you are still seeing the message, you will want to factory reset the device. 


Afterwards, the device will prompt you to finish any updates or set up that is needed. 


Let us know how it works out!

Hi my left controller is doing the same thing I have tried all the trouble shooting and nothing. Left controller fails to update. How can I fix this? I can't even get passed the white start screen. Brought this off a friend so actually never got it working yet due to the left controller.


Hey Thehenrys65! To clarify, did you mean that you have tried the methods we outlined in our previous response? If the issue is still persisting after trying those steps, please get in touch with our email/chat support team so they can provide step-by-step instructions to resolve your issue. You can connect with them using this link here.