Showing results for 
Search instead for 
Did you mean: 

Link Cable Performance Issues | Stutters in headset while flatscreen view is smooth | MSFS 2020

Level 2



I really hope to get some helpful feedback here, I've spent well over 10 hours trying to figure this out now and it's starting to drive me insane.


Issue: When pushing my PC close to the limit, I get stuttering/jitters and visual artifacts inside the Quest 2 especially when moving my head. Meanwhile, when I just move the headset around with my hands and look at the flatscreen projection, everything is perfectly smooth and clear there. 


So my suspicion is that even when the rendering is working fine and delivering sufficient FPS, something keeps the data from being transferred fast enough to the headset. The stutters and artifacts are worse in game, but even occur in the Oculus Link Home view (inside the headset) while running a 2D GPU stress test that pushes my GPU. So the issue really must be that when the GPU is close to maxed out, something throttles the data transfer over the link cable to the headset (at least that's my best attempt of making sense of it).


System Information: You can find the exact components here. My computer is brand new and I just built it this week, primarily for MSFS and VR (and both).

Ryzen 7 5800X3D
RTX 3080 12 GB


32 GB Corsair Vengeance LPX 3600 MHz

I'm running Windows 11 (this might be part of the issue?)

I can run regular PCVR titles without issues with absolute maxed out settings (e.g. Half Life Alyx) at max resolution and 120 Hz (Oculus Device Settings). 

I spent hours and hours optimizing all VR settings to get decent FPS (around 45) in MSFS 2020. The frustrating part is that I see a perfectly smooth and beautiful result in the 2D projection, but the view from inside the headset is completely different (stutters, jittery, artifacts. Especially when moving my head around). From what I read and saw, others with similar system specs are getting really good performance (just like what I see on my flat screen projection). Something in my setup is preventing the frames from being properly delivered to the headset.


Things I've tried

- Updated all drivers (especially USB controllers)

- Tried different cables (even a super short high performance USB-C to USB-C cable with 3.0 Gbps test result)

- Played around with all settings (Oculus, Tray Tool, Debug Tool, MSFS), until I realized that's probably not the issue
- Tried SteamVR Runtime instead of Oculus

- OVRServer_x64 is set to real-time priority (I didn't actually change that, it was already set) 


I read often times that people get better performance with VD even compared to the link cable. Unfortunately though, I do not have a great router and don't have my PC connected via ethernet. So even in regular PCVR titles, the latency is unbearable (same for Air Link). When I tried using VD with MSFS, it didn't seem to fix the issue, but it's hard to tell if it was just the poor WiFi connection. 


Has anyone ever experienced something similar before (perfectly fine 2D projection, but issues inside the headset)?


Any advice would be greatly appreciated, thank you!


Level 2

Seems like I can't edit my post, so I'll add here: I was thinking a lot about if this could be related to the video encoding. Does somebody know if the 2D view is the image before it was encoded (and decoded again)? I guess that would make sense, but still does not help with finding a solution. I especially don't understand why other people with similar specs and settings apparently don't have this issue.

I have almost the exact hardware you have and am experiencing exactly what you describe. I'm running windows 11 and have been fighting to get a playable session in VR for the last 6 months. it's so frustrating. my next step is to rebuttal everything from scratch on windows 10.