Showing results for 
Search instead for 
Did you mean: 

Link not supplying power to Q2

Level 8

Ok so this just started the other day, my quest 2 will no longer charge via the Oculus link cable, and when I play PCVR the Q2 battery is discharging fast, I'm talking lost 40% charge in 10 mins.

After playing around I have found a strange issue, the link is plugged into the USB C on my MoBo and when checking power outputs for USB ports the Quest 2 port is showing 0 power output, yet the link cable works fine just stopped supplying power all of a sudden.

unsure if this is a software issue in my PC, It charges fine via a wall socket


So far, I unplugged everything from other USB ports, no luck

Plug my Pixel phone into the link cable and it gets a power reading of 896 mA

Tested in a USB 3 port and the Q2 shows 500mA

Tested on another USB c-c in same USB C port and same issue 0 power output

Mobo is only 3 months old ROG Strix B550-F Gaming

if anyone knows a possible solution?


Updated with another test:

Using power cord that came with Q2, plugged into USB C port on back of PC, Phone plugged in reads 500mA, plug Q2 in and reads 0mA

245 REPLIES 245

Level 2

Yup, same issue here.


Updated bios, chipsets, drivers, nothing worked. Even tried fresh windows install. I am starting to wonder if it is an ASUS issue or Oculus. I have a TUF gaming x570 pro (wi-fi) motherboard and I am experiencing the same exact problem. 0 mA read in USBdeview with either usb C port but other devices give power. Computer is also only two months old. 

Level 3

Yup I've been having the exact same problem the past couple of days. Glad to know I'm not the only one at this point I think this is an Oculus issue. Hope that is gets resolved soon.

What brand mobo are you running?


I have the ASUS TUF Gaming X570 Plus WiFi

Level 8

Anyone had any luck with this issue, support don't seem to know anything yet.

Level 4

Seems to be an issue with the Quest 2 v26 firmware. Lots of others reporting the same, and only seems to effect USB-C to USB-C connectivity. I bought the Anker powerline cable (USB-C to USB-A) and that resolved the issue. 

Level 6

It's a common bug for v26. I don't think Oculus is going to fix this. 

v25 and v26 contains a lot of bugs that ruins the Quest 2 device. Worst case is bricking the device and no way to recover, best case is just Oculus Link problems (not charging, etc) and controller tracking delay increased. So you are lucky, just got oculus link not charging problem. Mine got Oculus Link not charging, random black screen frame, lost controller tracking, and significantly increased controller tracking latency that makes Beat Saber hard to play. 

Level 8

So brought a 10 buck USB3-C adapter and I'm back up and running for now .