Showing results for 
Search instead for 
Did you mean: 

Link not supplying power to Q2

Level 8

Ok so this just started the other day, my quest 2 will no longer charge via the Oculus link cable, and when I play PCVR the Q2 battery is discharging fast, I'm talking lost 40% charge in 10 mins.

After playing around I have found a strange issue, the link is plugged into the USB C on my MoBo and when checking power outputs for USB ports the Quest 2 port is showing 0 power output, yet the link cable works fine just stopped supplying power all of a sudden.

unsure if this is a software issue in my PC, It charges fine via a wall socket


So far, I unplugged everything from other USB ports, no luck

Plug my Pixel phone into the link cable and it gets a power reading of 896 mA

Tested in a USB 3 port and the Q2 shows 500mA

Tested on another USB c-c in same USB C port and same issue 0 power output

Mobo is only 3 months old ROG Strix B550-F Gaming

if anyone knows a possible solution?


Updated with another test:

Using power cord that came with Q2, plugged into USB C port on back of PC, Phone plugged in reads 500mA, plug Q2 in and reads 0mA

245 REPLIES 245

That's a good idea too. I think I'm going to do the same. After playing some more stuff, I think the Anker 10ft cable is just a bit too short for my setup. I prefer the weight. flexibility, and L-shape connector of the official Link cable as well. Hopefully Oculus will actually fix the issue though.

Not applicable

I have the same problem. I have spoken with the technical service, but they no longer answer me.


They stopped replying to me as well. Last I heard was, "We are going to look into this and will require more time to look into possible options available to you" and that they'd get back to me in 3-5 days. That was on March 10th. I followed up on the 14th and 18th - still no response. Hopefully this just means someone higher up is actually looking into it and working on a fix.

Level 3

This issue is just so anoying...

I have this same problem.  Checking in usbdview: 


Usb A to C cable - quest 896mA charge rate

Usb C to C cable - quest 0mA charge rate. 


Usb C to C cable - Samsung phone 896mA charge rate (using same port as quest)


I got the v28 update tonight too on my headset and this issue is still present. 






Yep, still have the issue on Quest 2 v28 as well. I went as far as RMA'ing my Link cable, they sent me a new one... same result. Support said they were going to pass along the info to the team. Hoping that maybe v28 of the Oculus PC software will do something to fix it, but so far, the PTC v28 doesn't seem to either. Will test it more to see if it "kicks in" at some point, since I know they do have a battery optimization feature, where the charging isn't supposed to happen until it's down to a certain percentage. Problem is that it wasn't charging at all, and the battery dies in like 1.5-2hrs. 

Not applicable

Yesterday I charged the batteries for the first time while playing (V.27). I had 25% and when I finished it was 43%. Using the USB-C (although it gives me a transfer speed of 0.7gbps 😞 , it works fine).
I have to keep doing tests ...

Not applicable

Same problem! I've had no issues using the official link cable USB-C to USB-A using an adapter. Used to be able to use it for 5+ hours but now I'm getting no charge coming into the headset with link.

I'm guessing it's to do with a recent Oculus update? Hoping v28 fixes it...

Unfortunately, the USB-C to USB-A adapter doesn't fix the issue for me. Had to use the USB-C to USB-A Anker cable to get it to charge while playing. The issue apparently started with Quest 2 v26 firmware, which is what I had when I got the headset, so it has never worked for me.

Is that with the official oculus link cable? I'll have to keep a closer eye on it. The whole thing has kind of kept me from playing PCVR stuff honestly, so I haven't been testing it much. I can confirm that v28 Quest 2 firmware fixes the low bandwidth issue in USB Speed Test though.