Showing results for 
Search instead for 
Did you mean: 

Link not supplying power to Q2

Level 8

Ok so this just started the other day, my quest 2 will no longer charge via the Oculus link cable, and when I play PCVR the Q2 battery is discharging fast, I'm talking lost 40% charge in 10 mins.

After playing around I have found a strange issue, the link is plugged into the USB C on my MoBo and when checking power outputs for USB ports the Quest 2 port is showing 0 power output, yet the link cable works fine just stopped supplying power all of a sudden.

unsure if this is a software issue in my PC, It charges fine via a wall socket


So far, I unplugged everything from other USB ports, no luck

Plug my Pixel phone into the link cable and it gets a power reading of 896 mA

Tested in a USB 3 port and the Q2 shows 500mA

Tested on another USB c-c in same USB C port and same issue 0 power output

Mobo is only 3 months old ROG Strix B550-F Gaming

if anyone knows a possible solution?


Updated with another test:

Using power cord that came with Q2, plugged into USB C port on back of PC, Phone plugged in reads 500mA, plug Q2 in and reads 0mA

245 REPLIES 245

Not applicable

Yes, with the official oculus link cable.

Level 3

I have an MSI Z270 Gaming Plus mobo. It has no usb-c ports so I have been using a 6-foot Anker usb-c to usb-a cable which worked well for a few months. Now my Quest 2 battery drains quickly while linked to my pc. USBDeview reports that the Quest 2 is getting 896 mA but it is not enough to keep me connected for more than about 1.5 hours. I don't know when this issue started as I have not been using pcvr much since the bitrate/refresh rate issues introduced with recent patches. These are sorted out with v28 so now I am noticing the battery drain as I am back in pcvr more.

I use my Quest 2 for pcvr flight sims.

Level 3

I have this same issue with the same setup(Q2, Oculus Link cable, and ROG Strix B550-F Gaming). It's been going for a few weeks now, and as a result of that I barely use my Q2 anymore. I thought I was alone on this, so it is good to see that other people are experiencing the same. I hope oculus will fix it soon.

Level 3


Level 3

Great, so "upgrading" to the Quest 2 has been a "downgrade" so far...

Level 3

I'm having the same issue as all of you. It's the Quest 2 at fault, not my PC or the cable. I'm glad there are some other dedicated troubleshooters on here. I only wish Oculus/Facebook put forth as much effort to resolve these issues that MAKE THE QUEST WORSE THAN THE RIFT

Level 3

I will share my experience in this thread in case it helps. I have a 16 ft USB A to C (Off-brand: sicotool) cable. I plug it into a USB A wall charger that was made for some 2020 Lenovo Android tablet. It will very slowly charge while you play. I would guess it takes about an hour to charge from near empty to 100% even with continual gaming. Obviously, I use Air Link or Virtual Desktop to play PC games if that's what I am doing.


So, you can game on the Quest 2 like described above. Of course, I initially wasn't planning on relying on wireless linking. I can still get to 100% charge then switch to wired Oculus Link, but I don't know if it makes things smoother or not in my limited experience. It won't discharge too quickly while gaming since it should be charging partially, so I would guess you can get more than an hour of gaming in. A brand new Quest 2 can't do much more than an hour of standalone gaming depending on the game, so this is fair I suppose. They say USB C to C should have much less problems with carrying power, but I can see I may have had issues had I gone that route. I have an ASRock / ASMedia USB 3 controller on the mobo, which is said to have problems with Oculus. It's an early USB 3.1 Gen 1 implementation. This is also before they had controllers with 2x2 or 4x4 support. I don't really know what that is, but I guess it helps power things.


For those having problems, I can only say that both BIOS and Windows drivers can be a pain to configure or install correctly. I think it's on the USB 3 hub device in Device Manager that you check to see if you are using a driver from the manufacturer rather than one that Microsoft provides. Another possible indication that you aren't fully configured is when Oculus Link USB test doesn't confirm that you have a USB 3 connection established with around 1 Gbps or more bandwidth on the port. Trying different ports on the motherboard can make a difference here. Using the USB C wall charger that came with the Quest 2 also sounds feasible as a workaround if you are OK with wireless linking and your router is a good enough.

Level 8

So since v28 my link cable has been working again and supplying power through the USB-C,  It still drains after around 1.5 hours of play but even when it hits 0% battery it continues to play fine as enough power is coming through the cable now.

Level 3

Solved my issue with this
I already bought a right angle USB C to C link cable so I also picked up a USB-A to USB-C adapter.

Now when I run the battery down, I simply plug in the power for the USB hub and I can charge slowly while I play.

I just changed out my motherboard to the Asus TUF Gaming X570 Pro and now having this problem with my Quest 2. 

Worked fine charging with the Oculus Link cable on my old motherboard but the new one doesn't charge. Seems to be a motherboard issue with the USB C port. As nothing on the Quest has changed, still on v28.