cancel
Showing results for 
Search instead for 
Did you mean: 

Link not supplying power to Q2

Zandil
Level 8

Ok so this just started the other day, my quest 2 will no longer charge via the Oculus link cable, and when I play PCVR the Q2 battery is discharging fast, I'm talking lost 40% charge in 10 mins.

After playing around I have found a strange issue, the link is plugged into the USB C on my MoBo and when checking power outputs for USB ports the Quest 2 port is showing 0 power output, yet the link cable works fine just stopped supplying power all of a sudden.

unsure if this is a software issue in my PC, It charges fine via a wall socket

 

So far, I unplugged everything from other USB ports, no luck

Plug my Pixel phone into the link cable and it gets a power reading of 896 mA

Tested in a USB 3 port and the Q2 shows 500mA

Tested on another USB c-c in same USB C port and same issue 0 power output

Mobo is only 3 months old ROG Strix B550-F Gaming

if anyone knows a possible solution?

 

Updated with another test:

Using power cord that came with Q2, plugged into USB C port on back of PC, Phone plugged in reads 500mA, plug Q2 in and reads 0mA

245 REPLIES 245

InvicTech
Level 3

Oculus should make an official power injector that has its own power supply or uses USB-PD standard to be powered. So the device would have a USB 3.1 input, a USB C power input that uses the Power Delivery standard, and a USB 3.1 Type C output to be used with the official Oculus Link cable. A solution like this would work on all PCs with a USB 3.1 port.

steeltarkus
Level 4

Doesn't charge on my friend's PC type c port either. Are we both "unlucky"? How come my PC used to charge it, but doesn't anymore? How come it still charges my phone on the same port/cable? None of this makes sense.

 

I just ordered a powered PCI-E USB card. The ones with type c 3.1 ports are harder to find/pricier. Doesn't even have a brand name but looks like this: https://prnt.sc/14eaz4m

 

I have a feeling I'm wasting my money but I will report results when it arrives.

This doesn't seem correct. I have tried 3 different USB type C 3.2 v2 expansion cards, including thunderbolt, none of them made a difference. This was after my onboard usb 3.1 stopped charging it. I tried it on another computer I have that is using a ryzen CPU 3700X and B550 motherboard, the current one I use is an intel z370 board, it didn't work either. It is some sore of software issue they haven't identified yet probably over at oculus so all they have are things that worked for a group of initial reports that involved lower power ports. I had a thought that it might be people with side quest. I wonder if everybody here has installed side quest?

steeltarkus
Level 4

Interesting. I have side quest installed, and my Quest 2 is on developer mode. That could have something to do with it maybe... 

I'll try uninstalling Sidequest and maybe turning off developer mode when I get the chance.

cjgrobbs
Level 2

Regarding Sidequest, I have this issue without having ever installed it. My Quest 2 is also not in developer mode. My friend also has never installed Sidequest but is in developer mode and has the same issue.

The only thing that is consistent between our setups is that we both have X570 chipset motherboards.

I had the issue before installing Sidequest, and continue to have it after uninstalling and factory resetting my headset. Might be worth seeing what motherboard everyone has. I have an ASUS Z370-A. Maybe it's mostly effecting ASUS and/or a certain generation chipset? My USB-C port is by ASMedia, which I've heard can be finicky, but that still wouldn't explain why type C expansion cards aren't working either, or why the same port and cable will charge other devices.  

 

I do wish they'd treat this with a bit higher priority. It's hard to justify getting into a Quest 2 game or social app when I know the battery is only going to last me a couple hours max. It's like they don't want me to spend time on the platform. 

zedian
Level 2

Hello, i believe to have the same issue.

 

I bought the quest 2 last week (downgraded from CV1) i am using the official link cable and it will not charge from PC both while playing with link and when leaving it connected overnight.

It is a big issue for me as i would ideally need at least 4 hours of lifetime when playing PCVR with the link cable

first i thought it was my MoBo Type-C power supply being insufficient but even after buying a PCIe expansion card that listed 5V 3A my headset still won't be charged.

 

I ordered a Type-A to Type-C usb 3 cable from Anker and hope this would be a solution but i have no hope at this point and i am seriously considering returning the Q2 i am seriously dissapointed in the product.

 

Specs:

OS: Windows10

MoBo: RoG strix X570-E
PCIe USB expander: SilverStone SST-ECU03 usb-controller
Official Link cable 

steeltarkus
Level 4

My USB PCI-E card arrived, I installed it aaaaand... the Quest 2 doesn't charge on it. I know, shocking development.

Not a single %, not even overnight, not even with the Quest 2 turned off. It stays at the same battery % or slowly discharges, despite it indicating it's charging (orange light).

 

And yes the PCI-E card is powered, by SATA. I used a molex to SATA adapter at first and thought maybe that was an issue power-wise, so I went and connected a SATA power cable directly from my PSU to it, and no difference. The card's port also charges my phone fine, needless to say.

 

At this point I've ruled out my motherboard, my cable, my entire PC... how long until Oculus admits there's something wrong here?

Krispy_1
Level 2

Same problem as other, Quest2 drains within 2hrs via official Link cable plugged into the MoBo's USB-C port.   Problem seems to have become significantly worse within the past two months.  My Quest 2 was purchased in Janaury 2021 and is on the latest firmware.

 

Specs:

OS: Windows10

CPU:  AMD Ryzen 5 3600X

GPU: AMD RX 5700xt

MoBo: TUF Gaming x570-plus wi-fi X570-E

Wish we could get an answer about this issue. Has anybody heard back from Oculus support?