cancel
Showing results for 
Search instead for 
Did you mean: 

Link not supplying power to Q2

Zandil
Level 8

Ok so this just started the other day, my quest 2 will no longer charge via the Oculus link cable, and when I play PCVR the Q2 battery is discharging fast, I'm talking lost 40% charge in 10 mins.

After playing around I have found a strange issue, the link is plugged into the USB C on my MoBo and when checking power outputs for USB ports the Quest 2 port is showing 0 power output, yet the link cable works fine just stopped supplying power all of a sudden.

unsure if this is a software issue in my PC, It charges fine via a wall socket

 

So far, I unplugged everything from other USB ports, no luck

Plug my Pixel phone into the link cable and it gets a power reading of 896 mA

Tested in a USB 3 port and the Q2 shows 500mA

Tested on another USB c-c in same USB C port and same issue 0 power output

Mobo is only 3 months old ROG Strix B550-F Gaming

if anyone knows a possible solution?

 

Updated with another test:

Using power cord that came with Q2, plugged into USB C port on back of PC, Phone plugged in reads 500mA, plug Q2 in and reads 0mA

245 REPLIES 245

Yea, that's doodoo:

"Get blistering-fast data speeds while powering your device at the same time. (Requires a USB-C port providing sufficient current.)"

 

They proudly put it on their own website...

And in the specs they even list the cable being capable of 3A of current

 

Official Link Cable 

SharonHala
Level 3

i also have this issue....
cable not faulty.. it chages when plugged to the q2 wall charger

mobo or pc not faulty too cause my phone charge at 900ma when connected with the same cable on the same usb c port...

this is an outrage how they can sell us a 80$ cable claiming it is capable of powering the device while connected and it wont even do that!

Hey @SharonHala! This is never what we like to hear! It sounds like there might be an issue with the cable or cable housing. Does the headset charge fine while using other cables, or charge fine using other power sources such as wall outlet or usb? If the cable is damaged, please consider putting in a support ticket here so we can get to the root cause of this issue!

If you have any questions or concerns, please feel free to reach out to us! Cheers!

the cable is fine. i wrote i tested it with the wall charger and it is charging with no problem!
and my pc is also fine because i tested 2 phones with the link cable while connected to my pc and it is charging..

this is a problem on your end im afraid

@MetaQuestSupport As I and many others have pointed out, the cable works fine when charging a USB-C phone, but it won't charge the headset from a PC/Laptop USB-C port. This indicates that the problem is with the headset. The headset jack works fine (it will charge from an AC Outlet), but there must be something in the headset firmware or headset hardware that's causing power not to be drawn where every other Android Phone and tablet I have works from the same cable over the same port.

I've already opened a ticket for this issue and went back and forth with support for months. Even went through an RMA of my Link cable. Last I heard from support was that "the issue is being investigated and a software/firmware update will be made available once a solution is available" - this was back on June 16th. Feel free to message me for the ticket number if you want... not sure if it's allowed to be posted here.

 

Not being able to charge the headset while playing a massive game like Half Life Alyx through PC VR just really kills the headset for me. The battery life is atrocious and makes it seem like you don't want people spending time or money on your platform. 

I, like many on this thread have tried a bunch of different things to fix this issue. I have installed 4 different PCIE USB C adapters, none worked, I have tried different cables, none worked, I even tried another Quest 2 headset, brand new, didn't work. From what I have been able to tell, it's the USB oculus driver causing the issue, an update to the link driver is required to fix the issue. 

PeterView- this forum moderator seems to think it should be charging the quest 2. 

https://forums.oculusvr.com/t5/Oculus-Quest-2-and-Quest/Charging-while-linked/td-p/755597

 

I also recall this being part of the promotional material, and support told me it was supposed to charge my quest 2 as well. So it sounds like you got some bad info from support. 

I also had no issues playing while the quest 2 was charging when i first got the quest 2, so I think something has changed in the drivers to cause this issue. 

MattGorilla
Level 2

Chiming in with the same problem. I'm using the VRCover link cable and a TUF GAMING X570-PLUS motherboard.

 

When using the link cable, the headset battery depletes extremely rapidly, even though the headset claims to be charging in the settings menu. Similarly, the headset does not charge when I've got it in standby while plugged into the same cable, using the same USB-C port. The headset charges without a problem while plugged into a wall outlet.

 

On the other hand, when I plug my phone into the same cable, in the same port, the phone "charges rapidly" while drawing 2 amps.

 

In sum, the cable seems fine, the cord seems fine, and the headset charges fine when it's on the wall.

 

Is this a software issue with the headset?

Anonymous
Not applicable

I think the fact that Facebook/Oculus have very little competition in the VR space, they are really dropping the ball on supporting this issue. Ridiculous to have an $80 cable that can't provide sufficient power to charge while using PC VR.