cancel
Showing results for 
Search instead for 
Did you mean: 

Link not supplying power to Q2

Zandil
Level 8

Ok so this just started the other day, my quest 2 will no longer charge via the Oculus link cable, and when I play PCVR the Q2 battery is discharging fast, I'm talking lost 40% charge in 10 mins.

After playing around I have found a strange issue, the link is plugged into the USB C on my MoBo and when checking power outputs for USB ports the Quest 2 port is showing 0 power output, yet the link cable works fine just stopped supplying power all of a sudden.

unsure if this is a software issue in my PC, It charges fine via a wall socket

 

So far, I unplugged everything from other USB ports, no luck

Plug my Pixel phone into the link cable and it gets a power reading of 896 mA

Tested in a USB 3 port and the Q2 shows 500mA

Tested on another USB c-c in same USB C port and same issue 0 power output

Mobo is only 3 months old ROG Strix B550-F Gaming

if anyone knows a possible solution?

 

Updated with another test:

Using power cord that came with Q2, plugged into USB C port on back of PC, Phone plugged in reads 500mA, plug Q2 in and reads 0mA

245 REPLIES 245

LVNDSCAPE
Level 4

I write this update now 3 times and 2 times it has been deleted after posting telling me i am not logged in 😕

So i hope it comes through now and i write it shorter.

 

Quest Firmware V33 seems to have fixed this now.

The official 5m fiber optics and the VRCover 5m fiber optics cables do charge now during activity as also in power off mode using usbc 3.1  gen 2 ports on my pc with Quest 1 and Quest 2.

 

It even charges in activity mode with battery state under 10% ( tested on my Quest 1 so far )

 

Can you confirm this ?

 

I still am unsure how much power you can receive in activity depending on how you use the quest 2 i mean

opening a picture app or a browser compared to a game.

 

So is the planned goal from Oculus that i can imagined endless game now powering it sametime or will the battery just being reduced slower and i can play a bit longer?

Actually the powering using a wall plug is much faster compared to the usbc even its working now but i doubt a power consuming game does not cause a battery drain now that way so you can play like "4 h" in a row.

 

 

 

Peterview
Level 3

I am caught in a never ending series of messages from different people within their support department who send me around in circles checking or changing things that I have already tried.   Still, left with a headset that used to charge fine via the link cable connected to my PC, and now doesnt.  So frustrating. 

Anonymous
Not applicable

-Firmware V33
-Original oculus link cable usb-c
-My desktop
-Nope, still doesn't charge while playing games on steam

jacks_disciple
Level 4

So this has been going on for 7 months and it's still not fixed. This is getting ridiculous...I can't use my quest 2 for more than a couple hours. You guys really need to fix this. And fast!

 

Anonymous
Not applicable

You all need to file support tickets. The more that do so, the more likely this will be fixed.

Agreed. I already went through all of that and even RMA'd my Link cable. If everyone in this thread RMA'd their Link cable, I can bet they'd start paying attention.

just did my support ticket.

Anonymous
Not applicable

WOW, i think i found the problem.

My desktop motherboard :
ASUS ROG STRIX B550-I GAMING
-1 x USB-C Gen 1 - header.

My laptop :
RAZER BLADE ADVANCED
-Thunderbolt™ 3 (USB-C)

The problem is not the oculus link cable at all, but the usb-c's transfer speed.
I just tried it with my laptop, and it still works perfectly.

The difference between USB 3.1 Gen 1 and USB 3.1 Gen 2 is only in terms of speed. USB 3.1 Gen 1 supports speeds of up to 5Gbit/s while USB 3.1 Gen 2 supports speeds of up to 10Gbit/s. ... They wanted to name USB 3.1 Gen 1 and Gen 2 "SuperSpeed USB" and "SuperSpeed USB+" respectively, but the industry never caught on.



WHAT IS THUNDERBOLT 3? 
---------------------------

Thunderbolt 3 ports look exactly the same as USB-C ports, and indeed, the connector is physically the same from a plug-in perspective. In many cases, they can do everything that a USB-C port can, except much faster. Indeed, Thunderbolt 3 is a superset of USB-C; you can plug a USB-C-only device into a Thunderbolt 3 port on a computer, and it'll work just fine.

Thunderbolt 3 lets you transfer data at up to 40Gbps. That's twice as fast as the 20Gbps maximum throughput speed of the fastest USB-C ports, and four times as fast as the original Thunderbolt interface. 

Hope this will help others, who have been just as frustrated as me.





Anonymous
Not applicable

So you're saying that USB 3.1 Gen1/2 are insufficient to transfer video and power simultaneously? I have an Asus X570-I motherboard with USB Type C 3.1 Gen 2 port and I can't get sufficient power even if the Quest 2 is not on.

Anonymous
Not applicable

Yes, that's what it seems like.
I have no problem with my thunderbolt port and it has always worked (from day one) and even with the oldest quest firmware. NEVER any issues.

The razer blade laptop, can't handle VR too well. Not thick enough for good cooling, so it runs hot and shuts off.
That's the only reason why i bought my new desktop XD
I might look for a different motherboard with thunderbolt 3 now, or wait and see if the rtx 4080 series, will add thunderbolt port, on their new cards. That would save me for a lot of money and trouble XD