Showing results for 
Search instead for 
Did you mean: 

Link not supplying power to Q2

Level 8

Ok so this just started the other day, my quest 2 will no longer charge via the Oculus link cable, and when I play PCVR the Q2 battery is discharging fast, I'm talking lost 40% charge in 10 mins.

After playing around I have found a strange issue, the link is plugged into the USB C on my MoBo and when checking power outputs for USB ports the Quest 2 port is showing 0 power output, yet the link cable works fine just stopped supplying power all of a sudden.

unsure if this is a software issue in my PC, It charges fine via a wall socket


So far, I unplugged everything from other USB ports, no luck

Plug my Pixel phone into the link cable and it gets a power reading of 896 mA

Tested in a USB 3 port and the Q2 shows 500mA

Tested on another USB c-c in same USB C port and same issue 0 power output

Mobo is only 3 months old ROG Strix B550-F Gaming

if anyone knows a possible solution?


Updated with another test:

Using power cord that came with Q2, plugged into USB C port on back of PC, Phone plugged in reads 500mA, plug Q2 in and reads 0mA

245 REPLIES 245

Level 3

did anyone tried doing a factory reset to the headset to see if it fixes this problem?
im thinking about trying it but dont expect much tbh

EDIT : sadly it didnt work. i just factory reset the device and first thing tried to charge it through the computer and it but it still wont charge 😞

EDIT 2 : also restore bios settings to default didnt work

EDIT 3 : fresh install of windows on a new drive still same issue

Level 2

I find it odd how the USB-C to C doesn't charge the headset, yet the standard USB to USB-C does.


I've had to revert back to using my old Anker USB cable for this.  Sure it drains quicker than it charges but 3 hours vs 6-9 hours is a no brainer.  The only downside is that it is less stable...stable enough but I may or may not get a disconnect from SteamVR (which sucks when playing rhythm music games!)

Level 4

Came back to confirm USB 3.0 to USB C cable works for charging and playing and seems to work better than the Link cable overall, no issues and it charges the headset. After 2 hours I was at 89% on the battery. It's available here:

Level 2

Thats they type of cable I meant, but maybe its dependant on what you're playing, as I am sure after 2 hours on VRChat my battery would have drained more...or that thats a better cable than my Anker one? I dunno.

Level 2

For what its worth, I'm actually seeing the same problem since the last software update on my Quest 1's as well. They charge fine with an A->C cable, but the Link C->C cable no longer charges. So it definitely sounds like its a software defect, not a hardware defect. 

Level 2

I've got the same issue as the subject, all of a sudden it stops charging while playing on the link.

The main thing I've noticed after PC restart and Quest2 shutdown it's charging until I launch any app on the headset like Popular 360 video or link desktop.

I've repaired the PC Oculus app and even played a game and it was charging but it stopped somewhere at night.

So I've deleted the PC Oculus app with the RegOrganizer app there is a useful option to clean up the register and files after usual uninstallation to clean up all configs especially debug tools settings cuz the repair didn't clean it.  Also, I did Factory Reset through the mobile app because it stopped even after I watch videos on the headset without the link.


Right now I'm playing and the headset charging same time. I have the Type-C Type-C 16ft Aliexprs cable and Asus TUF GAMING Z490-PLUS Motherboard




I’ve been trying to sort this problem for some 120 days now with Oculus Support.  They have replaced my actual Oculus and my Link cable which has not fixed the problem.  Terribly, after a large number of emails back and forth with customer services, they start all over again with the original questions/trouble shooting and you get caught in a never ending loop.  Is there a way to raising an official complaint?  Do they have a complaints policy? 

Level 3

Just to add to these woes - having gone around in circles with Oculus support repeatedly where they replaced both the official Link cable and actual Oculus for me, I purchased one of these:


Oculus Link Cable 5m, 90 degree Link Cable with 5Gbps data transfer and up to 3A fast charging, USB ...


This cable charges my Oculus fine while connected to my PC while gaming.   The official Link cable will not charge at all.   It used to work previously before the software updates.  

Level 4

This is similar to what happened to me only my usb port didn't charge or work with data at all.  I was promised a replacement 6 weeks ago because I only had it for one week until I had to send it back. I still don't have it back and I'm thinking now I should just ask for the broken one to come back because Oculus support have done nothing but lie the entire time I have asked them questions.  

Thank you for the solution to what might be the Occam's razor for this non-charging issue. To be blunt, the official link cable supplied by Oculus is possibly incapable of carrying the current load of the headset. This replacement cable is comprehensively described in Amazon as having the current carrying capacity of 3A. Stiffer, thicker and more suited for the task, I optimistically ordered one which should arrive on Thursday. We'll see. Right now my headset is deeply drained down to 1% or less, if possible. It does not charge.