cancel
Showing results for 
Search instead for 
Did you mean: 

Logging into Facebook from embedded browser disabled

CptnShiny
Honored Guest

Trying to get my Gear VR up and running on Samsung S9. Occlusion VR app says Continue with Facebook, but then says Logging into Facebook from embedded browser disabled. Tried logging into Occulus, but it says the account has been linked to Facebook -- so I can't log in either place. Any ideas?

10 REPLIES 10

MetaQuestSupport
Community Manager
Community Manager

Hey CptnShiny! We understand you're having trouble logging in to your Facebook/Oculus account. This is because Facebook blocks out embedded browsers due to their risk assessment. To try and work around this we suggest enabling two-factor authentication. To enable this:

  1. Open the Facebook app on your device and log in to your account.
  2. Go to Settings & Privacy and expand it using the downward-pointing arrow to its right.
  3. Select Settings and tap on Security and login under the Security section
  4. On the next page, scroll down to find the Two-factor authentication section and tap on Use two-factor authentication.
  5. Under Select a security method, select Authentication app and hit Continue.
  6. Click on Set up on the same device under the QR code
  7. When prompted to add the token to your device, tap YES.
  8. Once it’s added, go back to the Facebook app and enter the 6-digit code you see on the Google Authenticator app.
  9. Hit Continue.

We hope this helps resolve your login issue. 👍😊

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

debsugar
Honored Guest

literally how is this POSSIBLY supposed to help?

 

I did try it. it did absolutely nothing to help, but how would it??

 

y'all really just don't care, do you? we bought the device and now we're on our own.

 

obviously this is a reply to OculusSupport but for some reason it posted like this.

Felipe57700
Explorer

I have the same problem, they are leaving our Gear VR for which we paid unusable!!!

Hello, I went through the same thing and it is solved by installing the Facebook app on your cell phone and you must log in with your data, then go to Oculus Gear and log in with face book and it will recognize your account, thus skipping the error

drjohnpacy
Explorer

was having the same problem... i fixed it this morning.... THERE ARE 2 OCULUS APPS.... the one you download on Google play IS NOT the app you use for the Geer VR... 

I was having same issues.. when I put my phone into the Geer headset, I'd get a message saying that I'm not logged into the Oculus App.. when I logged into the (wrong) oculus app I'd get a message saying imbedded browser was disabled... 

Anyways, I found an article that pointed out there is a Geer Oculus app that downloads when you put your phone into the headset.... I found that app on my phone this morning, logged into it with my FB creds and... WOOOOHOOOO..... my Geer VR is back in action!!!

HackAzz
Explorer

Hi, I had this problem fixed.

I removed my FB app, and reinstalled it, logged in, and after that removed all Oculus apps, inserted my phone, asking download Oculus app, after installing the app, Boom Shakalaka! let me login!

Hope this helps!

Care to share a link to the other app?

the other app downloads when u plug fon into gear vr headset....

Thanks. Enabling two-factor authentication fixed this problem for me. In fact, with another Android game I was locked out of my account and unable to log in, and enabling two-factor fixed that too.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?