cancel
Showing results for 
Search instead for 
Did you mean: 

META 3 Not powering on!

myminions83
Honored Guest

We have a Meta 3 Oculus that suddenly went black and will not power back on. The last update on the app shows it to be charged. It was left on the charger overnight. We also tried plugging it in a different location. We have tried holding down the buttons for 30 seconds, waiting 5 minutes, and then doing it again. This item was purchased 4 months ago. HELP!! 

1 REPLY 1

MetaQuestSupport
Community Manager
Community Manager

Hey there, @myminions83! We don't want a black screen to continue to hold you back from enjoying VR, so we'd love to look further into your headset!

To help us take a deeper look into the device, we would like to invite you to send us a PM with the following details: 

  • Confirm if any LED lights are present on the outside of the headset.
  • Make sure to remove any third party accessories 
  • Attempt a factory reset on the device 

From there, we'll continue working to make sure you're all set! To send us a PM, either select our name to get to our profile page, or click here while signed in to the community. Next, click "Send a Message" to privately message us! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?