Showing results for 
Search instead for 
Did you mean: 

Many issues with Rift S which seem to me like hardware, but could it be software?

Not applicable
Am new to VR and Oculus. I have a Rift S which I am trying to get setup and working through issues but feel reasonably strongly they are hardware.

I am having several inconsistent issues.

Issue 1. 

With the usb and display port plugged in the headset shows as connected in the Oculus software. The Touch controls also both auto pair fine. Everything green, no apparent issues. When putting the headset on I see the VR environment for possibly 0.5 - 2 seconds and then the visual goes black and I get the error message 

"Oculus has detected a hardware issue that is preventing you from setting up your headset. Please check that your headset is connected and that all cable ends are firmly seated. If you are still having trouble, you can also select Try Again to repeat the setup process."

It seems that the Rift S disconnects when I put it on. I know there is a sensor at the inside front of the headset that allows the software to know you are wearing the headset (wake it up). Activating this appears to be what causes the headset to disconnect. If you take the headset off it reconnects again after a few moments and you can repeat the same process a few times with the same result. If I do this 2 - 4 times in a row eventually the Rift S stops connecting and I get the issue of "Firmware update required" and "No DisplayPort connection". The firmware version will now display as 0.0.0. This is incorrect and suggests to me that the connection to the headset has been lost completely hence the software it doesn't know the correct firmware version. At this point the USB connecting still shows as being fine.

This happens 90% of the time.

Issue 2.

I connect the Rift S and I get the "No headset audio" issues. This is easy enough to fix by changing it in my windows setting or unplugging / replugging the usb. However it's odd that it happens possibly every 510 or so attempt.

Issue 3.

Similar to issue 1. However when I put the headset on the eye pieces show a frozen screen. that's rotated on its side and distorted. I can tell it's the Oculus shop home screen. I can do nothing and need to restart the Software

Issue 4.

Controllers will not pair. In this case the controllers do not pair automatically. I pair them manually and all appears to go find. The wizards find the controller and connects them. However after the wizard they are still not show under devices in the Oculus software at all. I can do this multiple times in a row and they will just not connect.

Issue 5.

A couple of times I have put the headset on and it has not cut out. Insteead it has shown the calibration screen / play area screen on the Oculus shop home. However turning my head does not change anything. I can see the blue lines when I move the controllers so it's not frozen, but the headset is not tracking at all.

Issue 6.

Possibly 1 in every 30 or so attempts involving disconnecting and reconnecting the USB / Displayport I actually get into a mostly functional VR environment. This is either in the Oculus shop or the SteamVR. However the tracking works very poorly. Sometimes I turn my head and nothing happens. Other times the view jumps all over the place.

Issue 7.

Any time I can actually get into VR the controllers do not work properly. However this might be me misunderstanding something / something not configured.

Basically I pick up the controllers but in VR they stay on the "ground" I can point them to select things, but the hands in VR alwaus stay stuck in their starting position at the floor plain.

Issue 8.

Also when in VR often the left controller is not functional. It shows as connected, but I can't do anything with it. Possibly it's in sleep mode but nothing wakes it up.

Issue 9. 

If I just connect the Rift S and all connects fine then just leave the pc alone and doing nothing generally it will either lose the usb connection, display port connection or both, sometimes within minutes, sometimes it takes 20 minutes. Sometimes I will connect, disconnect, connect, disconnect and so on without me doing anything


I should point out here that I have had all of these issues in exactly the same environment and without changing anything else whilst following the same steps every time. Given the range of issues, that I get different issues seemingly at random from the same steps and without changing anything else this screams hardware issue to me.

For the record here is what I have done to rule out other problems. 

1. Rift S is connected to a powered usb 3.0 hub which is intern connected to a usb 3.0 port on my pc. I have read sometimes there can be USB 3.0 power issues hence the powered hub.

2. I have disconnected all other usb devices, other than mouse and keyboard.

3. I have ensure the cable is properly seated in the headset and the displayport on the gpu

4. I have ensured the displayed port I am connecting to is the one on the gpu, not mobo (mobo does not have one)

5. It's the latest version of the Oculus software as of today (Jan 2nd 2021)

6. Windows 10 current version with all updates

7. Have ensured Nvidia driver is the latest

8. Have ensures my USB ports are not set to sleep after a given time.

9. I have confirmed that the sensor that activates when you put the headset on is what triggers the issue, no a lose cable that is effected when the headset is moved. To do this I have left the headset still on the desk and gently covered the sensor with my finger. Same issue.

10. I have installed the Rift S drivers using the installer from C:\Program Files\Oculus\Support\oculus-drivers with anti-virus turned off to ensure these are installing correctly

11. Rift S is using the latest Firmware

12. I have unplugged all pc monitors but 1 and my pen screen

13. The screen I have left connected is my smaller lower res screen in case my larger monitor was an issue somehow (42 inch monitor so not common)

14. Have tried the other display port on my GPU

15. Have tried other usb ports on my hub and a usb 3.0 port on my mobo.

16. I have tried to use the headset in steamVR to see if some issues seem to be only in the Oculus software. Same issues in steam VR

17. Have tried this on a second computer with the same results.

This is the first time I have tried using the headset etc so it wasn't working them stopped, I just doesn't seem to work to begin with. Any thoughts appreciated.

Community Manager
Community Manager
Hello @taihavard If you haven't already, could you please create a support ticket with us here, and include the troubleshooting steps you have already completed. Thanks! - Clint
If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?