Showing results for 
Search instead for 
Did you mean: 

Media Sync Button Missing


In attempting to share photos taken within a game, I ran into a problem. I'm only able to share photos and videos taken by the Quest 2 capture itself. Every guide says to allow media syncing, but that little cloud button doesn't appear. Several other people have had this problem. Nobody has found a way to fix it. The Quest is updated to the latest software, and is paired with the Oculus App.


Accepted Solutions


After countless restarts and several weeks of waiting, the media share and cloud sync button FINALLY appeared. I don't know what it took, but I guess it was patience. No Factory Reset was needed.

View solution in original post


Community Manager
Community Manager

Hey there! We see you can't share your awesome game pics. That's a drag! Let's dive in and find a solution!


To avoid any misunderstanding, can we ask how you took the pics within the game?


Do you have Media Syncing enabled?


Files can only be shared to Facebook News Feed, Facebook Groups, and Messenger within the Files app.


The Files app only recognizes the following pic types:







We recommend you try the following:

  1. Uninstall then reinstall the Oculus mobile app and restart the headset.
  2. Try rebooting the headset
  3. Enable Cloud Backup and perform a factory reset


Let us know if this is helpful. If the issue still persists, please contact Meta Store Support at for further assistance.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Community Manager
Community Manager

Hi. We're reaching out to see if you need further assistance. Please let us know. We're ready to help!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honored Guest

I have the same issue.  And no, don’t point me to your “fix”, cause the button in question doesn’t exist.


Same issue here. 

Oculus Support had me factory reset the headset, uninstall/reinstall the Android Oculus app, even try with a completely different phone.

I'm still missing the buttons inside the headset in the files app, they simply don't exist. I'm running latest firmware, latest Android, latest updates, etc...



Honored Guest

same issue here, i’ve tried doing everything they listed and it still infact does not work. the button isnt there, its so upsetting. 

Honored Guest

To update my post, I have an ongoing ticket with Oculus for this issue. To test if this is an account-related problem they had me sign up for a temporary new account to test (using a different email address) and then factory reset and log into the app with the temp account.


This confirmed the problem was my account because on the new one cloud sync worked.


They have now escalated my case to am engineer who will be fixing my account.




I have the same issue no media sync file button no cloud share, this occurred directly after updating my headset and linking my meta account to Facebook account, no files showing in the oculus app on my phone , gone through every current provider d diagnosis online including factory reset. Also checking everything is connected as should be . Let me know if oculus fixes whatever the issue is with your account , cheers 


UPDATE: After completing factory resets, the cloud save button has returned, not sure why this was issue occurs however this does need to be sorted out , I believe it’s to do with the recent update on oculus quest 2. All functions have now returned to my device in terms of syncing media and reviewing it on the mobile app 

I can confirm this. I had an open ticket with Oculus and the last troubleshooting step (after already attempting one factory reset) was to create a new oculus account and see if the issue exists there (it worked fine with the new temporary account). Well when I factory reset AGAIN to switch back to my main account - suddenly this is now working.



Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?