Showing results for 
Search instead for 
Did you mean: 

Meta Horizon Workrooms (Beta) throws WorkroomsOCGatekeeperClientService error



I currently own an oculus quest 2 and recently installed Meta Horizon Workrooms (Beta) last night.  It worked perfectly fine the entire night. All the features were great, and it launched successfully. However, I tried booting it up this afternoon and it made me set my desk boundary and then it loaded in the loading screen for a few seconds. Then suddenly, it throws an error that says:


An unexpected error occurred

Failed initializing the OCGatekeeperClient

(WorkroomsOCGatekeeperClientService) service.

Please use the Oculus button to quit Workrooms and relaunch the app.


I tried relaunching Workrooms, reinstalling it, and rebooting the quest. Also, my quest is up to date.


Accepted Solutions

Honored Guest

I figured out how to solve it!

You need to have Horizon Worlds installed on your headset as well. Seems like Horizon Workrooms is using a service from that app to work. You may have to run Horizon Worlds once after you install it as well, I'm not sure. I was having this issue for days and I thought to try it and it fixed it for me!

Note: This worked for me on my Quest Pro. I imagine it'll work on all headsets but can't necessarily promise that

View solution in original post

Meta Quest Support
Meta Quest Support

Hey everyone! So sorry in the delay in responding on this thread. I know every single one of you are wanting to get back into Workrooms (Beta), and I have some good news! 


There was in fact a bug that some users experienced when trying to access Workrooms (Beta) from Nov 4-7. According to our team, this has now officially been fixed! The Workrooms (Beta) app should now be working as expected for all Meta Quest 2 and Meta Quest Pro users. 😁


For this fix, you may need to update your headset, and uninstall and reinstall the Workrooms app, so please try that first if you're still getting the error.


If you're still having this issue with Workrooms (Beta), please let us know (and send a screenshot if you can) so we can get the engineering team to look into it further.

Make sure you smash that Kudos button!

View solution in original post



I forgot to mention, I spent 30 minutes searching the web and found zero results, no matter how I rephrased it.


Getting the same error as well and haven't been able to use Horizon Workrooms at all because of this issue.  Did the same exact troubleshooting steps you did and got the same results.


Yes same issue, I can't get any of the new movement SDK functions to work either which could be related to this.

I noticed that my Quest Pro don't give any permission prompts when starting apps using the Mo vement SDK, I suspect this error is related. I only installed workrooms to see if any app could actually these new functions but seems not.

Incredibly buggy release, I've spent at good 6 hours re-installing, re-importing, creating new Unity projects etc. but nothing works. And no one even responds on these forums in any of the threads of these issues, even if they're weeks old. Incredibly frustrating.

Honored Guest

Exact same issue on my new Quest Pro as well.


I have exactly the same error message. Reinstalling the app or restarting the Quest did not help. The quest is up to date and new.
Problem exists with me on the Quest 2

Honored Guest

I have the same error ? How to fix it?  Please Oculus Meta, help us.


ive been trying find someone like me for me is i deleted it by mistake and redownloaded it and then the message popped up.


I too have the exact same error, and this is the only page on the Internet that mentions it. I've opened a case with support about it, but I'd like to get some more information from you folks to share with Meta.

Are you all running this on PC? I'm on Windows 11, but I also tried it on my old laptop that is running Windows 10 with the exact same error. I'm also confused about whether or not the Oculus client should also be running on the PC while you run Remote Desktop. I would think not, but I've tried it every which way from Sunday and always the same error. I can play Half-Life Alyx and other games using Air Link and Steam VR which works fine, even though according to this page I was directed to by Meta Support:

my graphics card (GTX 1050 Ti) isn't supported, even though I'm running Air Link just fine, and this article is actually about Link with cable, which I also tried by the way, only to get the same error. Anyhoo, please share if you learn anything.


I've been searching for over an hour and still found nothing. I contacted a support agent and they didn't help much either. I even tried to load workrooms on my pc to see if it was a problem with the headset.

oh but guess what

Workrooms isn't even in the oculus desktop app.

If I ever find a solution, I'll be sure to post it immediately. Meta help us!