cancel
Showing results for 
Search instead for 
Did you mean: 

Meta Horizon Worlds "Unable to Travel"

CompleteAnimeFan
Honored Guest

Was playing last night and tried to join a friend of mine who was in another world and sudden got the error that said "We are unable to take you to your destination.". I can't join friends, I can't join worlds, I can't even go to my own home world. Anyone know any possible answers.

Before anyone suggests, I've tried the following; 

Resetting the app

Resetting the headset

Changing my language to and from English

Uninstalling the app, reset headset, reinstall

FACTORY RESETTING 

 

Any help would be appreciated. 

2 REPLIES 2

Goatoftsushima
Protege

At least you can get horizon worlds to work,apart from downloading it about a month before it came out in the uk,playe on it a few hours then the morning after I couldn’t even find it on my headset and it’s said unavailable ever since

We appreciate you getting in touch with us, and with the information you have provided we can see how this might be a confusing situation for you. However, don't worry; we have you covered. Click on the link to open a support ticket so that our squad can look into this matter for you in more detail.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!