Showing results for 
Search instead for 
Did you mean: 

Meta Loop Issue

Honored Guest

So I have had my quest set up with a meta/Facebook account for a while now and haven’t run into any issues; however my s/o recently got her own quest 2 and trying to connect her headset to a meta account has been a nightmare. We have tried following the steps shown in the headset through her phones browser and it is prompting us to login to either the Facebook account or the oculus account, and both redirect us to the right page, but here’s where the problem lies: 

When we choose to log in through the oculus account (which we have had set up for some time now and things were working fine until the meta update) we could enter as far as the email, and then it throws an error that we need to sign in with the Facebook account that her meta is linked through. So we follow the directions and go back to sign in through Facebook instead. But when we use the Facebook login option, it is prompting us to create a new meta account because there isn’t any data found to be transferred, so we have tried creating a new meta account (thinking we haven’t set up the meta account properly) and it then prompts us to log in through the oculus app. Which as stated above, will not let us log in because it is requiring that we log in through Facebook.

The prompts are just leading us in circles, where one option tells us that we can’t move forward without logging in with the other first and keeps cycling between the two, throwing constant error messages.

We even went as far as creating a new account on the quest itself to hopefully set up a new meta account with but (and I presume this is an issue with the device not being connected to meta and constantly popping up the connection page) none of the account information will load. On top of that when we try to create a new account we just receive an error message saying “something went wrong, try again later” and we have been receiving this message for days. I have restarted the device multiple times, updated the software, and checked/changed internet connections to eliminate any problems that may be caused on our end. We are also locked out of the meta quest app because it’s prompting the Facebook login and then like before just goes back and forth, error messages, etc.

We are at our wits end with this process and her device is in a purgatory of a soft-lock state where we can’t really use it for anything but scrolling the settings menus. If anyone has advice on what to try, anything is appreciated! Thank you!


Honored Guest

I don't think the quest app should be requiring you to log in with Facebook 🤔 did you try uninstalling and re-installing the app? I suspect that you might be in a state on the app where it thinks you're still trying to migrate a Facebook/Oculus account over to a Meta account, while you're trying to use a brand new Meta account. In this case, reinstalling the Quest app should allow you to log in with your new Meta account.
You should eventually be able to link your new Meta account to the existing Oculus/FB accounts, though that may be a little tricky. Based on your experience so far.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?