Showing results for 
Search instead for 
Did you mean: 

Meta PC software can't reach Meta Quest Link services.

Honored Guest


as you can see in my screenshot somethings not right. ive searched the internet but i found nothing, i use windows and this error came when i installed the software and it went through a scan to verify everythings alright.
I also tried the "repair" button many times and uninstalled and reinstalled the program a couple of times but its still not working. (also restarted my pc many times and i also have a stable internet connection.)

Does anyone know what i could try?


Honored Guest

I'm having the same issue, already got in contact with support, but none of what they gave me worked, i'm trying to get in contact again to see if it is possible to rollback to an update before "Meta quest link" was a thing

Community Manager
Community Manager

Hey there, @chill_alter! No worries! We'd be happy to help you get Link connected so you can get back to enjoying PCVR! Thanks for letting us know what you were able to try already. Also, @Joao.G.Bach if you haven't yet tried any of the steps bellow please give them a shot too. While there isn't a way to rollback to previous updates, we are always looking for ways to improve, so feel free to share your ideas on that on our ideas forum

Please try the following :

  • Please ensure your Link connection is properly established
    • Open the Meta Quest PC app on your computer.
    • Turn on your Quest headset.
    • Plug your USB 3 cable into a USB 3 port on your PC, and then plug the other end into your headset.
    • A message displays in VR prompting you to Allow access to data. Select Deny. If you mistakenly 'Allow' the prompt, you must unplug your USB cable from the Quest and plug it back in.
    • When prompted to Enable Meta Quest Link, select Enable to begin remote rendering using Meta Quest Link.
  • Ensure Air Link is disabled in Settings on the headset
  • Repair the Meta Quest PC application 
    • Go to and click Download Software.
    • Select Repair
    • If Windows asks you if you are sure you want to open this file, click yes.
    • If Windows Defender prompts Windows to protect your PC, click More Info, and then click Run anyway.
    • If your antivirus software restricts the file from opening, temporarily disable your AV and continue.
    • Please remember to re-enable your antivirus software once you have completed the repair.
    • Allow the repair process to run, download, and install.
    • Launch the Meta Quest PC app.
  • Install the latest Meta Quest drivers
    • Close the Meta Quest PC app.
    • Press the Windows key + R on your keyboard to open the Run command.
    • Enter C:\Program Files\Oculus\Support\oculus-drivers. (The file path may be different per user based on the install location.)
    • Open oculus-driver.
    • Open the Meta Quest PC app, and then try to connect your headset again.
  • Confirm your USB power settings
    • Open Device Manager
    • Expand the universal serial bus controllers section at the bottom of the list.
    • For each item listed under universal serial bus controllers:
    • Right-click and select Properties.
    • Navigate to Power Management.
    • Ensure that the options to save power are deselected.
    • Not all these listings will have these power management options, so we can skip ones that do not and move onto the next item in the list until completed.
  • Check for Selective Suspending
    • Right-click the Start menu icon.
    • Click Power Options.
    • Click Additional Power Settings.
    • Click Change plan settings.
    • Click Change Advanced Power Settings
    • Find USB Settings
    • Make sure that the Selective Suspend Setting is set to Disabled.
  • Confirm if you've received the latest USB driver and operating system updates
  • Enroll in or opt out of the Public Test Channel (PTC)
    • Open the Meta Quest PC app on your computer.
    • Select Settings in the left menu.
    • Select the Beta tab.
    • Next to the Public Test Channel, click to enroll.
    • Manually reboot the headset.
  • Cold-start the Quest headset
    • With your headset on, hold the power button on the right side of your headset down until you are prompted with a shut-down screen.
    • Select Shut Down and wait a few minutes before you reboot your Quest headset.

Let us know if that helped or if you are still having any issues. We look forward to hearing back from you all and seeing how things are going! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Community Manager
Community Manager

Hey there, @chill_alter. We are reaching back out again seeing if the steps we provided helped you out any.

If not then please feel free to reach back out to us.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hello, sorry i took so long to response I tries all steps but it still doesnt work. I even Factory reseted my pc but it still says the same thing. Are there any other solutions?

Thank you @chill_alter for reaching back out to us and letting us know you are still having issues with connecting to Quest Link. At this time, we will need to gather some additional information from you. In order to do so, please reach out to us in a PM and we will be happy to dig deeper into this issue! Please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message. ​

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Knock, knock! We wanted to check back in with you to make sure you receive the best support for your Quest Link issues! Please send us a PM, or let us know if there's anything else we can help you with!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I was like you and tried a lot of things the only thing that worked was ;

Hit Start, type Services. In Services, scroll to Quality Windows Audio Video Experience. If the service says Disabled, right-click, Properties. Set the dropdown to Manual. Click ok. Try starting the service. Start Oculus again.

If QWAVE is ok, look at the timestamped service log, e.g. %localappdata%\oculus\Service_2024-05-10_19.35.10.txt for clues. Usually there will be some error toward the end that comes up just before everything start shutting down.    

thats from

another thing which I though was the culprit is the windows redistributable that meta app installs. 

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?