cancel
Showing results for 
Search instead for 
Did you mean: 

Meta Quest 2 Black Screen

NayyBuddahfly99
Level 2

My Oculus Quest 2 has a black screen. I’ve restarted and factory reset but nothing has worked. I also even tried to reset it, it’s powered on. I hear the start up music, but the screen is black. When I go to power it off it displays the startup screen for a nano second before it shuts down.

10 REPLIES 10

Killer_Game20
Level 2

I am having the same problem did the same thing 😕

MetaQuestSupport
Community Manager
Community Manager

Hiya there @NayyBuddahfly99! We realize that this situation is difficult, but let’s try and find a solution. So, what we understand so far is, your screen is black, you've attempted various troubleshooting steps but have been unsuccessful. On occasions, turning the headset off and leaving it charging for a max of 2 hours can do the trick.

Please keep us posted if you were able to resolve the issue. If you have any questions or concerns, please don't hesitate to reach out. We are here to help!

Metalbuckeye
Level 2

Having the exact same issue...left it charging it came on again for about 15 minutes then went black again.  Super frustrating.  Will there be a better solution than "turn it off and back on again?"

Hey there, @Metalbuckeye! We can definitely understand your concern with this issue, since it would stop you from enjoying your VR games and that's definitely pretty far from an ideal situation. Have you also tried out a factory reset? If so, and if it didn't help, we'd recommend reaching out to our other support team via email or live chat for more in-depth assistance. They'll be able to get this resolved one way or another! That goes for everyone here, by the way. If factory resetting didn't help, reach out to our other support team here

ANNELISE15
Level 2

Did you ever figure it out 

kanator
Level 2

I have the same problem.

 

  1. The headset is on but the screen is just blank
  2. Restarting does nothing. It just turn on and goes back to black after the meta logo
  3. Battery level shown as full when turn off or on

The headset is on the latest version.

For me it turns out the proximity sensor (between the lens right above the number) is no longer sensitive enough to detect when I put my headset on. I tried cleaning it but it only works when I completely cover the sensor with something 😐

Hi there. We see your concerns in regards to the black screen issue on your headset. Thank you for attempting all troubleshooting steps to resolve this issue. We deeply empathize with you and understand how this may frustrate you and impact your gaming experience in the VR world. Let's not waste any more time and look into all of our service options. So that we can look into this further, we will need to gather more account information from you, so we would like to invite you to our private messaging service. Please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.

I am having a similar problem except mine is black with text saying tracking lost and the controllers are not working at all. Please 🙏 help me.

If you've already performed a factory reset and have the same black screen constantly showing, we may need to look into other possibilities for you @qu12as. We suggest you Submit a Ticket with us, we'll be able to assist further within that platform and look into next steps!