cancel
Showing results for 
Search instead for 
Did you mean: 

Meta Quest 3 - Official Link Cable - Quest Link, Not working!

Piplington
Explorer

Hello All,

This really is shocking, I have been talking to the support for over a week. The official link cable is very expensive, you would expect that feature to be "plug and play" like a regular console, I can't fathom how this experience with the Link Cable is so fundamentally broken that the software doesn't know it is linked at all. 

A few quick things to mention, Air Link works, though I have a mesh wi-fi connection in a shared household, and I have spent £90 on a useless wire. So my interest is full resolution VR, no stuttering on a high end PC (I personally can't stand playing on the low end standalone graphics, some things look good. But I like my PCVR)

My PC specs are high end, 30 series Nvidia and 12th gen I7. 

I have tried the Developer Mode and Public Test Channel "work around".... If I were actually a developer I would also be shocked by this experience, because as far as I can see, all my cables are currently doing is charging the headset. So there is no file sharing notification (I have seen this once) and no interaction with PC.

The official solutions so far have been to completely obliterate the software and to re-install or repair it. None of this has worked for me. 

Well, at this point I don't to hear that it is my PC, my wire, my hardware, my software or my set-up. Meta need to make this actually work. 

4 REPLIES 4

jogipuff
Honored Guest

Hi, i absolutely have the same problem and been trying to troubleshoot for a week now with no luck. Airlink works fine but i cannot get my link recognised. Tried 4 different cables so i know its not about cable. I am starting to think that usb port on Q3 is the culprit here. I have the same problem on my laptop too so its not driver or windows related. Maybe Oculus software? 

TomCgcmfc
MVP
MVP

@Piplington  Sorry to hear you're having problems using Link.  I use the official link cable connected to my z790mb usb3.2 type-c port and it works great with all my Quest headset (Q2/3/Pro) and maintains my heasdset battery above 80% for a very long time (+5-6hrs).  With Link, make sure you start off with a fully charged headset.

Works great with all my games and flight sims.  Like everything PCVR it usually depends a lot on your PC specs and settings imho. 

I recently posted my Link (and Air Link) settings on the msfs2020 user forum.  You may want to try the general settings I'm using (ODT, meta link pc app, and win11).  Depending on which rtx3000 series gpu you have, you may need to move the metal link pc app device graphics res slider down a few notches from full right.  Lowering your refesh rate can also help (80Hz is my sweet spot).  For general/global nvidia control panel 3d settings leave everything defaults except power = prefer max performance and change the default quality below that to high performance.

https://forums.flightsimulator.com/t/settings-with-qpro-and-q3-using-link-4th-march-2024/632996/1

You should also do the meta link pc app usb speed test to check the quality of your connection.  You should get at least 2.2Gbps (I get 2.4Gbps).  Also, make sure to go to your windows device manager usb ports/properties and make sure to disable any power saving options.  Also, disconnect any usb devices you don't need while using Link, so you don't run out of usb bandwidth.

I hope you eventually manage to get Link working ok.  As much as I like the freedom of wireless with Air Link (or Virtual Desktop) I still get the very best distance clarity and lowest latency with Link.  Good luck mate and cheers.

i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 6400 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro, Q3, w/Link and Air Link, Vive Pro1 with Etsy lens mod and Index Controllers

Thanks for the reply. 

i'm not sure the USB speed test works before the headset is even detected. I am stuck on the set-up stage, let alone any graphical settings and such. 

I hope so too, I do believe it is not an issue with my hardware or settings, as I have followed every recommendation so far. Their app just does not work. 

I can't share files to my quest either

yeah, maybe their USB connector breaks immediately... I haven't see the pop up for file transfer since i got it either (plugged in previously with a phone charger to transfer data