cancel
Showing results for 
Search instead for 
Did you mean: 

Meta Quest 3 air link used to work, doesn't anymore

simos_mcmuffin
Honored Guest

Hi,

I've had this issue that air link will suddenly stop working almost completely, being completely unusable in it's frame rate. It used to work without any problem and I completed half-life Alyx for example with smooth and steady frame rates. It borked itself in the middle of my first playthrough and I tried everything to fix it,

  • reinstalled Oculus app and removed all their folder from /Appdata (no bueno)
  • reinstalled GPU drivers (no bueno)
  • factory reset the headset (no bueno)
  • factory reset my wifi 6 router (tx/rx links show 1200 consistent in the headset at 5Ghz, TP-link archer AX53) (no bueno)
  • reinstalled SteamVR (no bueno)

Weird thing was that after 8 hours of rage inducing troubleshooting I gave up and bought VD and was immediately disappointed at the lack of multi-monitor support, but the link was stable at least. Went to bed, got up next morning and found out that the air link now worked again completely fine, oh joy! Refunded VD and got back to gaming, but now a week later it has again resurfaced and I'm out of ideas what to try.

I do have some interesting diagnostics now though. I was testing on improving my air links visual quality via Oculus debug tool and was still getting steady framerates with the settings shown below.

simos_mcmuffin_0-1704403622945.png

Link was completely steady without any lag or stuttering. and now the next day, it has once again s**t the bed completely and I have already gone through all the earlier troubleshooting tests with no luck. One MAJOR weirdness is that when I now start up the air link, it shows weird values in the Oculus Link performance monitor, almost like the Oculus app is misidentifying the headset for some reason and setting up the encoders with an invalid settings, for example using the wrong color space, or at least reporting so.

simos_mcmuffin_1-1704403796903.png

Note that this does not happen when using a link cable as shown below.

simos_mcmuffin_2-1704403901868.png

The air link is essentially getting more and more delayed, which is evident when looking at the logs from the OculusLogGatherer. The link is getting delayed up and over 33 seconds.

 

 

 

In the AutoAnalysis, it's just endless "could not retrieve round trip frame timing"

 

 

 

I think it both cases when the air link stopped working, the OVRserver process crashed, so it might have corrupted something, which then caused the air link to stop working, but I'm not completely sure how I was able to reset it back to working, as it suddenly just seemed to work just fine suddenly. Maybe the oculus software got some minor patch, that re-wrote the corrupted file when it updated?

3 REPLIES 3

hardhotsweet
Protege

Get the Dlink VR Air Bridge

Hey there, @simos_mcmuffin! We want your Meta Quest Air Link to have a great connection so you can have the best user experience possible. 

Updates can resolve certain issues, but since you are still having some trouble with the connection, please try the steps here if you have not done so already. That page also provides a lot of information that may help you improve your connection. Please let us know if you still need help.

 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

MetaQuestSupport
Community Manager
Community Manager

Hey hey! Just checking in to see if you're were still in need of our assistance!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?