Showing results for 
Search instead for 
Did you mean: 

Meta Quest Link Status : Meta quest link services unjoinable (RIFT S)

Honored Guest


As I wanted to dust off my Rift S and start playing again in VR, I was taken to download the new windows software (and only one available) meta quest link. I also downloaded the app and logged into my oculus account. However, after trying to make a clean uninstall (removing files from program files, and appdata folders), and reinstalling the software a few times, making sure my graphics card (rtx 4080) firmware was up to date, as well as windows update, turning off the gaming mode setting in windows, I can't get passed the unjoinable meta quest link services page on the software. My computer and phone are on the same network, My headset in connected, and I removed every peripheral on my computer except one screen, mouse and keyboard. 

I must say that I didn't find anything online that helped me, so this is a last cry for help before I clonclude that the hardware I bought some years ago is dead even if it's still supposed to be working.



Community Manager
Community Manager

Hey @FlashWing_As! We would love to assist you with your Rift S. We completely understand how it can feel when you are not able to get back into VR and enjoy the benefits of PCVR. Thank you so much for trying some steps to get this fixed. We would like to go ahead and gather some additional information to better understand the situation. If you could please provide the information requested below, we would really appreciate it. 


  • What error messages, if any, do you see?
    • What is the exact error message that they see?
    • If there are no errors, what is the exact behavior the customer has experienced?
  • Has a device ever worked before?
  • What else changed when you first noticed the behavior?
    • Did any of the devices (phone, headset, PC) receive any updates?
  • Does the headset work when not connected to a PC?
    • Test basic functionality (navigate menus, launch and using an app)
  • Are you connecting a USB cable to a USB 3 port?
  • Try another compatible cable, if possible. For example:
    • Included USB Charging Cable
    • Meta Quest Link Cable
    • 3rd party retail cable (request a URL of the purchase page for the cable if the customer is not able to provide specifics)


We look forward to hearing back from you! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi, here are my answers :

I have this message, before even having a prompt to connect my hardware:

Capture d'écran 2024-06-05 192158.png

The rift S worked a year ago, since then I guess there have been windows update mostly, but it did run at least once. (albeit with the old oculus software)

As for the other question, and my issue being for a rift s, not i can't make it work without the pc, and the cable is the one from the box. But i'm don't think it is a hardware issue.


Honored Guest

Also, yes I am using a USB 3.0 at the back of the motherboard, and I don't have / don't want to have to buy another cable, as the one I have worked fine prior to this issue, and has been stored correctly since then.

Community Manager
Community Manager

Thank you so much for getting back to us with this information. We have some things for you to try! 


  • Please check the link cable for potential damage. For example, twists, kinks, frays, or bent pins. If you observe any, please let us know.
  • If you are using any USB splitters or extensions, please remove them.
  • Make sure that the USB drivers are up-to-date.
  • Make sure that you first connect the USB cable, then connect the DisplayPort cable to the dedicated graphics card.
  • Try the headset on another PC, if possible.

Please let us know how this goes! If you are still experiencing issues after, please let us know. We're more thank happy to continue looking into this!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

The cable is in perfect state, with nothing broken or bent. As I said, I am plugging it directly to the motherboard. My drivers are also up to date. I am already plugging the usb first, then the display port, although the led indicator inside the headset stay orange and does not go white. I don't currently have another pc to try it with. 

You can try typing "ovrserver_x64.exe" into windows PowerShell to see what the problem is. I had the same problem before and it turned out that the user name of Windows was not in English and it was not properly recognized.

Honored Guest

Thanks for the tip.
Here is what I got :



I did not launch meta quest link prior to executing this tho, was it needed ?

But yeah it seems I am missing something, but even after repairing the software, it still gives the same error.



You can start to see, I remember if the path error will be displayed on the top.

Honored Guest

05/06 23:00:52.381 {!ERROR!} [LoggingTools] Unable to purge server logs C:\Users\julien\AppData\Local\Oculus\OVRServer. Le chemin d�acc�s sp�cifi� est introuvable.

Failed to find interface factory 'GetOVRInterfaceFactory' in library 'C:\Program Files\Oculus\Support\oculus-runtime\server-plugins\RiftS\RiftSTracker.dll', error 127

Oncall not specified when initializing server MrServiceIPCServer in package .

05/06 23:00:53.218 {WARNING} [DefaultAudioDevicePolicy] Could not find Rift device for input falling back to Windows default
05/06 23:00:53.218 {WARNING} [DefaultAudioDevicePolicy] Could not find Rift device for output falling back to Windows default

arvr\projects\oculus_pc_infra\OAF\liboaf\core\JsonUtil.cpp(81) : Failed to parse manifest JSON data (1971038)

Failed to load HeadsetPlugin: EmulationPluginAddition; got error code: -1010

arvr\projects\oculus_pc_infra\OAF\liboaf\package\PackageManager.cpp(219) : Package does not exist: oculus-runtime (1971015) OVR57367903


Here are all the error messages I get. Hope this helps corner my issue. Thanks for the help

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?