Showing results for 
Search instead for 
Did you mean: 

Meta Quest Remote Desktop for Macbook Pro 2019 seems to be stuck on main screen ever after Login

Level 3

Remote Desktop on macbook pro 2019 seems to be stuck on main screen.


This seems to be stuck here, ever after successful login. Any ideas ?

Screen Shot 2022-10-21 at 11.51.50 AM.png



Level 3

Same result, v1. does not fix the loading issue on Intel based devices and Meta has seemingly bricked non-ARM devices from using Meta Quest Remote Desktop (for now?) -  65% of my endpoints are Intel based so this is really limiting who can use this tool. 

Same here, im still waiting 🥲

Level 2

Still an issue on my 2019 Macbook Pro.  

Level 3

Same! ... but worse here ..... 

Help! I've installed the Meta Quest Remote desktop on my Mac (Catalina 10.15.7) ... it just sits spinning, BUT the bigger problem is that now ALL my sound is gone and when I try to open Sound Preferences, it says "Could not load sound preference pane" ... is this a know issues?
It's super annoying because I actually just reinstalled this system because I had lost my sound but didn't know why ... seems like I just discovered why.
This page ( in the "Known Audio Issues" section says that I need to "Please run the uninstaller to completely uninstall Meta Quest Remote Desktop." ... where's the uninstaller?

Level 3

Ok, so I dug a little deeper and found the script .... I ran it as root and got my sound back without rebooting. 


In case anyone has the same issue, here's the location of the script ... "/Applications/Meta Quest Remote" .... I simply did a "sudo -i" and then ran the script as root. 

Level 5

@wikiliki @shaftoe173 @maVRick_Mike @Alonso.Abif  Sorry you are still dealing with this!  I haven't heard anything further about updates to fix this either, it's frustrating that we aren't getting any updates from Meta directly about the status of this issue. 

Last I heard they were aware of the issue but hopefully the team working on this is still actively working on the solution. 

You are welcome to join us over in the Horizon Workrooms Community, where we are actively trying to help each other and starting to track feature requests and bug reports in our Discord group.   

I was hoping if enough of us were to share the issue here in the forums it would make a difference to getting an answer but it seems like they aren't very responsive at the moment.  

I'll keep you posted on what we hear from the community as well!  One way around this issue in the meantime might be to run a Virtual Machine like Parallels until there's support for Intel Macs again.  

Are you all on intel-based Macs? That seems to be the only consistent issue we are seeing in the community. 

Hope we see an update soon!

The same thing happened to me with the audio, at first I didn't know it was due to the desktop remote (I formatted my mac 🥲) when I reinstalled the app I realized the reason.
Luckily I realized that by installing a previous version I solved the audio problem.

@Alonso.Abif  OMG, noo... reformatting the Mac all because of the remote desktop, so glad you know it now so you didn't feel like it was a hardware issue. 

Ugh, I feel your pain. That was the same thing I did. I troubleshot my sound issue for more than a day - not knowing the Meta app was the cause ….. so frustrating without sound. 

@vkkotha I just noticed you marked this issue as Solved but I think that may take it off the Meta and @MetaQuestSupport radar!   I think you intended to help point people to @maVRick_Mike 's helpful info but you may want to mark this as not solved if you have the ability to do that.   We still have some reports coming in about the issue over in the Horizon Workrooms Community