Showing results for 
Search instead for 
Did you mean: 

Meta Quest headset not downloading any games

Honored Guest

Ive been trying to download this game i got but every time i press on the download button it gets to 0% and then cancels the download. I’ve tried restarting the headset which didn’t do anything so i resorted to a factory reset but after that nothing is downloading still. so now im left with no games to play on the headset because of this problem


Accepted Solutions

Meta Quest Support
Meta Quest Support

Hey everyone! I brought this issue up with our internal team and they informed me that this issue should be resolved now! Please attempt to download your games again to see if their able to completely install, and try a soft restart of your headset if you haven't already and your downloads are still failing. If you're still having this issue, I recommend making a comment on the thread HERE, as that is where another Moderator has been updating other users on this situation! Thank you all for your patience during this time!

"They say that the best blaze burns the brightest when circumstances are at their worst."

View solution in original post


Honored Guest

Other posts here say there's an "install failed" message on their device when they try installing an app, for me, the app begins to install and immediately stops with no messages. It just goes back to showing me the download option. It goes a little like this:

  1. I click download
  2. It shows the progress bar for less than a second
  3. it stops showing the progress bar
  4. it shows the "download" button

No warnings, no nothing. It just doesn't want to let me do anything. I have been able to install apps in the past (I have steamlink and SuperHot VR, as well as some random Labs apps I was trying out, so at least I can play games with Steam VR). I already tried changing my wifi network, disconnecting and connecting from my wifi, restarting the device. Turning it off and on, and I don't really know what to do. I will not factory reset the device though, I will say.

I've had similar problems before with the camera app where it would say it's recording and immediately stop (but it wouldn't save the video), but the fix for that was to quit Steam Link and try again. I don't know what's wrong. 

I'm having the exact same problem with my Quest 3 right now.  Exact same symptoms and I've tried the same work-arounds.  I think this must be a problem on Meta's end.

Honored Guest

I just got my meta quest 3 about a week ago and I’ve been able to download a few games and apps and now I’ve tried to downfalls Netflix and when I click install it starts the queue then instantly ends it. It does this for all apps.

My quest3 was perfect and suddenly, I can't download anything.


I have 200gb of free space... 


So frustrating....  


So, I was having issues download a game, I would click the game to download, it would enter the queue then begin the download only to immediately stop downloading the game without any pop-ups or anything. I tried everything everyone recommended, but just decided to factory reset. After going through the set-up again I go to download my games only to be met with the same issues, now I have zero games to play with no way of downloading them. I've seen other people say they're experiencing the same thing, so there might be some server side issues or something. But some help would be useful 

Have the same issues, factory resetted, now nothing is working 

Exact same problem, and I just received this headset today

It's not just you.  I've got this same issue and it's being reported by others.  Looks like it just started happening very recently.

Having the exact same problem on my quest 3 right now.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?