cancel
Showing results for 
Search instead for 
Did you mean: 

Meta Quest update button not doing anything - PTC V66

remix826
Protege

Im on ptc v66 and I got the update for the official rollout of v66. When I click update the download progress pops up for a second and goes away. The button to update is greyed out and stuck “updating…” I’ve let it sit for quite a while. Reset several times and nothing. If you leave update and go back it has the option to update now again. Resets do nothing 

1 ACCEPTED SOLUTION

Accepted Solutions

TheeScientist
Meta Quest Support
Meta Quest Support

Hi everyone! 👋 I hope you're all doing well. I have some great news to share from our Internal team. It seems that the issue has been resolved! Now, to get things back on track, it would be recommended to reboot your headset. You can find the step-by-step instructions on how to do it successfully at this link here. It's super helpful and will guide you through the process smoothly. If you're still facing any problems, shoot a private message to @MetaQuestSupport. They'll be more than happy to help and take a closer look into the matter for you.

Don't worry be happy.

View solution in original post

158 REPLIES 158

Same exact issue.  Been on updating for 25 minutes, tried it twice.  And it always goes back to update option when I leave screen and come back.  Restart and reboot doesn't help. 

I feel like the dude in Mallrats, yelling when do I get to see the sailboat?! I’ve tried restarting so many times and nothing. 

LMAO Exactly!
I keep trying to decide when I want to hit update again, because once I do, I will sit unmoving, staring at the greyed-out "updating" button for way longer than I should.

sp0r3
Honored Guest

I’m not on the PTC and got the option to update today. Same exact issue. It would begin the process of updating then immediately switched to the greyed out button saying “Restart to apply”. Tried different WiFi networks and still no dice. This was starting to irritate me a bit because I’d been waiting for v66 for a week now and wanted to see if I could get the warping fix sooner rather than later. Grew impatient and did a factory reset. Now my headset is stuck on the update portion of the initial setup and the progress bar indicates “Over an hour remaining” and does not advance any further. I also can’t complete the setup without the update completing so now I’m stuck with what is essentially a paperweight. Lesson learned on exercising patience. Hopefully Meta Support can chime in here with some potential fixes as I have lost all functionality of the device at this point lol. 

That sucks, do a search for “update stuck”. I saw a few threads giving tips on this when I was looking for a solution earlier. Different problem than we initially had but hopefully you find a fix. I unticked the tab for the PTC, was given the option to update immediately. Updated and, I have zero of the new features I was waiting for. Maybe we got a bad server. 

Fust314
Explorer

I'm having the same problem. Spent the last couple of hours trying to figure out how to fix it. Giving up for tonight. Hopefully Meta will do something about it tomorrow.

Same story here

chichi1213
Honored Guest

I can't believe this issue came up yesterday and there hasn't been any official announcement yet.

I have the same problem, I press the "Update Now" button and when I go back to the menu it tells me to update the Quest to v66 endlessly.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?