Showing results for 
Search instead for 
Did you mean: 

Minecraft VR Broken by update v49

Level 3


I switched the 'OpenXR Runtime' option to make SteamVR the active one, Oculus somehow broke their OpenXR stuff in the update which in turn broke minecraft, not to mention every other game that uses it. Definitely a huge bug, thankfully so far the workaround seems to be working but that's no excuse to let the bug stay, really needs a fix!


I have been playing Minecraft in VR a lot lately and it was working just fine hours ago, before I went to sleep last night, however when I woke up and booted up everything (I use Quest 2 via Link cable), I was prompted with an option to update the software to v49. Ever since doing that, Minecraft has completely stopped working. ( I go into more detail here)

In short, my game works just fine in flatscreen but when launching through the oculus library or even by making a direct shortcut to the VR mode, it crashes or freezes for 5 minutes before ultimately crashing. Every time I try to launch via the software, 'Minecraft Oculus Launcher' is the program on my taskbar that is frozen, however even when I boot up Minecraft's VR mode directly using a shortcut, the game appears to begin opening for a few seconds, the red screen that shows Mojang's name appears for a single frame and the program crashes.

I only blame the v49 update because all week I've been playing MCVR as my primary game, hours at a time, and it worked just fine 8 or so hours ago (relative to when I updated and tried playing the game after) but suddenly the VR aspect of the game refuses to work? It cant possibly be anything else because the only difference between today and last night is the updating of the Oculus software. They made it so we cant roll back versions so I cant say for sure by doing that, but it cant be anything else.

I did every troubleshooting method you could think of short of fully resetting Windows 10 so I'm hoping this can either be fixed quickly in an update or maybe someone knows what I'm doing wrong?  If anyone else is unable to play MCVR, please let me know so i dont go crazy thinking its a problem on my end.    ;v;


Community Manager
Community Manager

Hey Mute_Crow, thanks for posting on the forums about this. We're sorry to hear that your device is having troubles opening Minecraft, it's not normal behavior and we want to get you the help you need! We would appreciate it if you tried a  Factory Reset. If the issue still persists at this point, hit up our Online Support Team via email, chat and/or callback for more advanced troubleshooting and warranty options!

Level 3

Same for me. Webxr doesn't work under v49 and the oculus openxr runtime. 

Hey, SmokeyJoe_92! We're you able to try the steps we previously outlined? If the issue still persists at this point, hit up our Online Support Team via email, chat and/or callback for more advanced troubleshooting and warranty options!

Level 3

I reinstalled the oculus software but that did nothing . I found more reports from multiple people with the same issue.

I set steamvr as the active openxr runtime and it worked again, so i think i use steamvr openxr until the oculus software isn't broken anymore...


Factory resetting my headset won't fix a PCVR game, especially when I discovered the problem was in fact on the oculus software side. The update broke OpenXR, having oculus set as the default OpenXR runtime makes it break, changing it to steam fixes it. I don't see how wasting a days worth of time reinstalling my full game library and losing all of my save data on my headset will fix a PCVR only issue that was so obviously caused by the update...


And if you somehow meant to 'factory reset' the oculus software, I tried that already. I repaired the software and when that didn't work, I did a full uninstall and reinstall which also didn't fix anything. The game worked just fine all week, I updated the software, it breaks

Hey there, @Mute_Crow. We can definitely understand your concerns regarding Minecraft VR not working properly. Since this is a PC VR issue, we'll want to review your logs which we can't do here on the forums. Please reach out to us through our Support Site and we'll gladly look into this some more for you! 

Level 3

Hi - can you confirm how you chose the SteamVR in your browser please? I can only see the options:


No Runtime




In steamvr I went into the developer tab in the menus, might have to toggle advanced settings. On the bottom was a button saying to set steamvr as default OpenXR runtime