cancel
Showing results for 
Search instead for 
Did you mean: 

My Camera app on Quest 2 won’t load

glitterfish1272
Honored Guest

Just as the title says, my camera app on my meta quest 2 headset simply won’t load. When I launch it, it sits on a screen with an ellipses and doesn’t change no matter how long I leave it. 
I have tried shutting down, restarting, and even factory resetting my device and nothing has fixed it. I would like to cast to a device of mine so I can show my gameplay to my friends via streaming through discord, but I’m unable to load into the app to even have the chance to do so. It’s super frustrating, someone please help me fix it 😞

6 REPLIES 6

MetaQuestSupport
Community Manager
Community Manager

Hey @glitterfish1272. We were in the area and saw that you were struggling to get your Quest 2 to cast. We do love that you enjoy VR so much that you're trying to show your friends. We would love to work with you to solve this issue and have you back to casting and sharing. We see you did tell us what you already did, and we do greatly appreciate that, for we wouldn't want you to retry the steps you already took. We do want to make sure you are casting properly, so if you click this link, you can see the steps on how to cast to a phone or computer. While you take a look at that link, can you also answer the following questions?

  1. When was the last time your "Camera" app worked and opened?
  2. Have you updated your headset recently?
  3. Is the "Camera" app the only one that is having this issue?
  4. Are you trying to use the app via standalone or PCVR?

We hope to hear back from you soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

MetaQuestSupport
Community Manager
Community Manager

​​Hello @glitterfish1272. We're just checking back in with you to see if there's any updates on the issue you're experiencing and if you still needed assistance. We're still standing by to assist you with any further questions as well. Hope to hear from you soon.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I am having the same issue. I wanted to cast my quest 2 to my Chromecast. But the camera app never loads. As far as I know it is the only app with an issue. I checked for updates for the quest 2, I think I am up to date. I am trying this standalone. I can't tell you when the last time was for the camera app to work. I used to cast using the built in share button. I never record my play sessions. But I do want to share it with family and friends when they come over.

For all intents and purposes Meta has removed one of the most important functions of the quest, the ability to cast. This is ridiculous and basically makes your products useless. Please fix this.

Hey there, @LukasTheBlue! We appreciate you reaching out to us regarding your inability to cast your Quest 2 to Chromecast and proactively taking the time to answer the question we asked another user in this thread. We're delighted to lend you a hand, but keep in mind that casting directly to a Chromecast device or TV is not fully supported by Meta and may not work with some Chromecast devices or TVs. 

 

We kindly ask that you attempt and ensure the following, then let us know if it helps: 

  • Ensure your Quest 2's software is up-to-date.
  • Try casting on a computer and/or phone.
  • Cast from another app (Netflix, Spotify, YouTube).
  • Ensure all three devices are on the exact same network. (ex. If the router has a 5GHZ and 2GHZ channel, all the devices must be on the same channel.)

We're looking forward to hearing back from you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hello, so sorry for the late reply! Funnily enough, almost immediately after I sent the original post, my camera app actually started working just fine. So as of now, everything works perfectly! I’m not sure what I did to fix it, it may have been a late result of the factory reset, or maybe it was a connection issue that fixed itself over time, I’m not sure. But the problem is solved now, so thank you for reaching out to me anyway!! Again sorry for the late reply, after it started working I kind of forgot I even posted this in the first place as I was more preoccupied playing my new game 😆

We're thrilled you're back in action, @glitterfish1272! We can't say for sure what may have caused this excellent outcome, but we appreciate you sharing! The important thing is that you're back to enjoying VR!

 

We also wanted to check back in with you @LukasTheBlue, to see if you'd had a chance to give those steps a try! Please let us know if there's anything else we can help you with!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?