Showing results for 
Search instead for 
Did you mean: 

My quest 3 isn't charging with my link cable but the quest 2 did.. anyone know why?


My quest 3 isn't charging with my link cable and I've had no problem doing it with quest 2 but it just stays at the same percentage.. I haven't tried the charger the comes in the box but It should be charging.

107 REPLIES 107

  1. What's the full version number of your headset? --
  2. What's the full version number of your PC app? --
  3. Is your PC app on PTC? -- I've tried both, live version and PTC and get same result. Would try PTC on headset but looks like that one is full.
  4. Any potential workarounds? -- none. It seems like the headset is capping itself at the amount of watts it will try and pull from a card honestly when connected over link cable vs doing same thing with an external battery pack that has same specs. Playing pcvr over airlink with battery pack that has 5V 3amps (15W) it will charge the headset up from being at 40% no issue. Plugged into a powered pci-e card with same power specs it will not do that and will still slowly drain. It's only charging at the rate the quest2 required to charge at to charge up while over link cable it seems.

Thanks for this! I'll get it passed over to the team.

I did want to ask though, does the Quest 2 'charge' (in a sense of gaining power as you play), or does the link cable prolong the battery life and have it drain slower than normal? (Or is it something different entirely?)

Just asking so I can have the right insight for them.

Sometimes it's okay to be a little Bing Chilling

Yes I can be at 20% battery in quest 2 and connect over link cable to PC and have pcvr software at max settings for resolution and 120hz and it will charge it up to 100% while actively playing Pop1

Awesome. Last thing for the moment, since it slipped my mind earlier. This is with the official link cable, or is it with a 3rd party by any chance?

Sometimes it's okay to be a little Bing Chilling

Both. Official link cable which I have multiple one brand new and both have same result. Aftermarket with a power supply inserted and both give same result 

Meta Quest Support
Meta Quest Support

Hey everyone! I've gotten confirmation from the engineering and product team. It looks like when in use, the headset may adjust the charging rate to optimize battery performance based on factors such as temperature. For safety and performance reasons, your headset’s battery also may not fully charge if it is plugged in while in use and exceeds the optimal charging temperature. Once the device is no longer in use and its temperature has returned to normal, your device should resume charging to 100% while plugged in to charge.
When plugged into a laptop/PC, using a USB port that is not Power Delivery-compatible and capable of 18W+ will slow down charging.

If you have any other questions or concerns, please don't hesitate to reach out to the support team through PM or back in this thread. We appreciate all feedback! 

Sometimes it's okay to be a little Bing Chilling

To be honest they should check those temp range values then as the quest 2 gets 5x as hot as the q3 here in same exact situation yet it still charges up and works fine while q3 slows down charging.


On the PowerDelivery part, are you saying if the port was a PD port it would charge up fine?


Suggest a update to the link cable page as it comes across you could play forever using it with proper USB port which isn't at all the case.

I'm not sure I've seen a USB port capable of +18W that supports power and data at same time that isn't PD based. 

This also doesn't really explain why it's only an issue over link cable and not airlink. Same exact scenario and using airlink with a battery pack it will take the charge up every time no issue but link cable with same exact spec USB charge ability and it will not.

"Once the device is no longer in use and its temperature has returned to normal, your device should resume charging to 100% while plugged in to charge"

It seems this feature is bugged and it works only sometimes ...

Other times you need to unplug it and plug it again.

Its not a solution. Quest 3 has a serious hardware or software related issue.... Its killing batteries fast...PLaying a video stream (not gaming just a looking a netflix video) and headset fully  drained to zeroe within 1 hour 50 mins??? 5000MAH fully addon battery zeroed win 26 mins? Elite straps with batteries died?

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?