Showing results for 
Search instead for 
Did you mean: 

My quest 3 isn't charging with my link cable but the quest 2 did.. anyone know why?


My quest 3 isn't charging with my link cable and I've had no problem doing it with quest 2 but it just stays at the same percentage.. I haven't tried the charger the comes in the box but It should be charging.

107 REPLIES 107

I mean, do you start with the quest 3 plugged into the PC and the power adapter plugged into the INIU cable? Or do you bring up the quest 3 completely, then plug in the INIU cable and power, etc. Or do you have everything plugged in when you start the PC and Quest 3 at the same time?

The best method I have had success with is plugin the charger to cable then cable to headset then with oculus open plugin to the pc. I have had to restart the headset sometimes to get link to connect but it usually works. I really recommend the inexpensive usbc tester I mentioned as it makes it possible to see if it’s drawing enough. Even if the head set appears to have the charge symbol if it’s not 8-9 volts it won’t keep up. If it says 5 it’s going to lose charge rather quickly depending on game 


Ahh got ya.

I always have the usb cable plugged into the pc along with the power brick. I would say I don’t usually have the Q3 actually plugged up to the cable if I reboot but whenever I do plug it in, I always get a pop-up that says would you like to connect to the link.

i did mention this in a much older post but if your having issues and haven’t tried doing a factory reset on your Q3, that’s when things seemed to start working better. Of course it was right around that time when an update came out. Just sayin, couldn’t hurt.

I have the same issue as well but both airlink and datalink connected to USB 3.1 port playing hl alyx the battery warning pops up at 44 minutes from 100% charge.

Same playing Asgards wrath plugged into 45w super charger adapter and 100w USB-C. Unless the device is off it just keeps draining. I haven't tested to see if it does drain completely to sglhutdown but it does drain to 7% and I shut it off to charge.

I did find a workaround. I strap a car battery to my chest and it run it off that.

With the 1980's security camera quality passthrough and inability to actually play games on this gaming device, I wish I had gone with the Pico. This is why rooting and custom kernels will likely be coming soon. Kinda like Bethesda, let the modders fix it. lol.

Considering the battery is always beyond optimal temperatures (48c idle and 60+ load) the battery will never charge unless it's turned off.

Sent it back to Amazon for replacement. And I'll send the replacement back, and so on until it works unless someone wants to be transparent and tell us the firmware is buggy.



I used a USB tester.

From the power supply, the measured current around 2A is the same using the link cable as it is for the charging cable, although the link cable has a little more voltage drop. Any statement that the link cable is not for charging is cr@p.

When plugged into the PC with the link cable, the voltage increases and current drops to almost zero. That means the PC is giving the voltage but the quest is not using it. Why? There is absolutely no good reason for this. I could understand they may want to reduce charging to reduce heat while using, but if I plug the link cable into the charger while using the quest, it will charge, so that eliminates that argument.

Not one reasonable explanation has been given for this issue. The only solution is to use airlink and use the link cable to charge from the charger. That cable is way too expensive with this limitation. Everyone should be refunded.

That's an excuse, meta needs to stop limiting thing on the software side. Forcing the use of proprietary hardware to make more money. Charging is a volts and amperage limitation not a cable. The link cables conductors are more than capable handling .5amps tired of having my headset dead when it has sat on the charger all day. Makes me want to sell it an go a different company 

Honored Guest

This issue is such a shame... But.. The device is still somewhat young so they might resolve this with updates. 

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?