Showing results for 
Search instead for 
Did you mean: 

New D Link air bridge stopped working


I just started using the D link air bridge Monday and for the first few days it worked fine. I tried to use it today and I could not connect to the air bridge. The quest 2 attempted to connect and failed with no message. I went to the oculus app and it just said error on the air bridge. Next I did a factory reset on the air bridge and now it won't complete the setup. It jumps to 20%, then to 10%, then to 15%, and I hear the usb disconnect tone and the setup fails. A few seconds later I hear the usb connect tone. If I just leave the setup screen up it loops like this disconnecting and reconnecting until I stop it. It remains connected when outside the setup. Is there a way to fix this or am I looking at a return and replacement?


Community Manager
Community Manager

Hey there! We hate to hear you're experiencing this issue after a factory reset on your Air Bridge. We would recommend reaching out to D Link to look into warranty replacement options

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!


I've run into a multitude of issues so far. Everything from the setup phase for the air bridge looping infinitely, just getting an "Error" in devices, not detecting the air bridge, setup completing but not being to connect on the headset, being able to connect to the air bridge and not being able to link to the PC. Every problem is fixed by uninstalling the device and driver in device manager and running the oculus driver program. After that, it works fine. I just have to uninstall and reinstall the driver every time I turn on the computer. I also noticed another awful side effect, so long as the air bridge is connected Windows can't detect any devices on the network whether wired or wireless. The bridge must be removed and the computer restarted. My device is not defective, it seems a lot of work needs to be done to the drivers to get it functioning well.

Honored Guest

I'm experiencing similar.  Was working like a charm for the first couple of weeks, now Windows disables the device if it even gets a whiff that I'm trying to use it. This is now interfering with reinstalling the software to run it as it gets disabled and disconnected before the install even completes. 

I've already been through an RMA and have the exact same issues with the replacement, so I know it wasn't a single piece of defective hardware either.


My process has evolved slightly, I no longer Uninstall the driver, only uninstall it from the system and refresh and this fixes my problems. I attempted an rma but was ignored, luckily I believe my device isn't defective, but this is a software issue.

Hi @HandsomeDevl, we understand you have an issue still with the Air Bridge. This is not what we want to hear from our customers, so let's try to see what we can do. 


Try the steps below to see if it helps:

  • If you’ve set up Air Bridge in the past and gone through the new user experience tutorial, you can factory reset your device from the PC app. To do this:
    1. Open the PC app
    2. Click Devices
    3. Click VR Air Bridge.
    4. Click factory reset.
    5. Click Reset to confirm.

Once you're able to successfully set up VR Air Bridge but the performance is suboptimal, try the following troubleshooting steps.

  • Make sure there are no other Wi-Fi devices or other headsets nearby that could be causing interference (ex: other Wi-Fi routers).
  • Review the Air Link Connection Troubleshooting Guide to see how you can use the benchmarking tool to test and troubleshoot your Wi-Fi connection performance.
  • If possible, always connect your PC to your router via Ethernet cable rather than Wi-Fi.

You can also visit our in-depth article about the D-Link VR Air Bridge to read about the numerous scenario and troubleshooting steps. Hope this information was useful and please don't hesitate to let us know if you have any other concerns. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honored Guest

I will add my voice to this discussion. Excuse the length, I'm trying to pack this with more search terms to help other people find this answer.

To that end, firstly thank you @Woogoo336 for articulating the problem so well and following up - it meant I was able to find this thread with some pretty vague search terms.

And thanks @HandsomeDevl for adding the RMA context that helped confirm that it was very likely a software issue.

My experience is that I have had the Air Bridge ("D-Link DWA-F18 VR Air Bridge" for the sake of accuracy and searchability) for a couple of weeks.  It set up very easily, exactly as shown in the instructions (plug it in, start up the Oculus desktop software, follow the on-screen directions).  I've used it for several hours and it worked almost flawlessly, even more so when I switched my PC to a wired/ethernet connection (and interestingly, it doesn't seem to matter if the ethernet connection is straight to the router or via a wifi bridge).

So the problem: I'd used the Air Bridge with the Quest 2 one evening, shut down the PC, and when I started up the next evening, it was exhibiting the exact behavior @Woogoo336 described.  As Windows (Windows 10 Pro in case it matters) started up, I could hear the sound of a USB device connecting and disconnecting over and over (same sound as when you plug in and eject a device - upwards tones, downward tones).  The LED on the Air Bridge was flashing, then off, then flashing and so on.  When I opened the Oculus desktop software, I also saw the percentage increasing, but because the Air Bridge kept disconnecting it never got past about 30%.

Obviously I tried a restart, tried different USB ports, unplugged and plugged back, the usual stuff. Then I tried @Woogoo336's solution of removing the device completely through Device Manager.  After doing this, the Air Bridge stayed connected, but it was recognized as an "Other Device", (a wifi adapter without a driver as I recall), and the Oculus desktop software could not see it at all.  So clearly now it needed the drivers reinstalling. But I could not find the Air Bridge drivers on D-Link's site.

The solution
for me was on the page that @MetaQuestSupport linked to (  The beta restart and factory reset didn't help, but running the "C:\Program Files\Oculus\Support\oculus-drivers\oculus-driver.exe" executable seemingly reinstalled or reinitialized the Air Bridge drivers.  The executable doesn't visibly do anything, so don't expect any windows or interfaces.  But from my recollection, as soon as I ran it, the device jumped to the correct location in Device Manager, regained the correct name in "Devices and Printers, and was recognized by the Oculus desktop software again.

From there, I ran it through the initial setup again, and everything was back to normal, I'm able to go in and out of Quest Link using the Air Bridge again, all good.  I've restarted the machine a few times since and the issue has not come back, although I fully expect it to happen again.

It's not clear to me what caused this issue.  I didn't change anything between it working and not working.  Possibly a Windows update - I have another USB device for which the driver regularly gets reset to the wrong thing when Microsoft pushes an update.  Either way, it's frustrating when something works fine and then just stops working without any obvious cause.

So thanks again to the folk in this thread.  If I encounter the issue again, I'll try to boil down the solution steps to the bare minimum and post an update.

Glad you got yours working.

My process if the device is in an error state, bootlooping or some other failure seen in headset like 2.5GHZ only or airlink fails to start:

Open device manager

Expand network adapters 

Right click the D-Link device

Click Uninstall Device

Leave "Delete driver software" UNCHECKED 

If your network adapter was disabled and remains disabled, enable it.

Click "Scan for hardware changes" (monitor with magnifying glass in the toolbar)

It should now complete the setup. If it does not:

CHECK "Delete driver software" and uninstall

Click "Scan for hardware changes"

Open oculus-driver.exe at C:\Program Files\Oculus\Support\oculus-drivers

Wait for install to finish and the device should be ready in oculus devices


I have not seen this issue in the last few days, so perhaps it was fixed.

I also have another process for improving usability. By default, the air bridge does not provide internet access. This causes the quest 2 headset to not automatically connect to the air bridge when it is available. It also obviously can't download updates or use online apps when connected. You can share your internet access to the air bridge which will fix all these issues and also allow airlink to ready up automatically.


Search "Network Status" in the taskbar and open

Click "Change adapter options"

Note the items in this list, one will be your active internet connection, either Ethernet or Wi-Fi. Wi-Fi 2 will be listed as the air bridge. There will also be one called "Local Area Connection*" followed by a number, 15 in my case. This is the device you want to share internet access to. 

Right click your active internet connection and open properties

Click the sharing tab

Check both boxes and select Local Area Connection* in the dropdown

You must now restart your computer, as this action temporarily prevents airlink from working. Also note this is undone if you uninstall the D-Link drivers.


Let me know if you have any issues or questions so I can improve clarity in the post.





Honored Guest

DLink Airbridge is the biggest piece of **bleep**! I'm about to either throw it in the trash or send it back. Absolutely Do NOT RECCOMEND> Never wants to connect. "Connected, No Internet" Non-Stop. Sometimes magically starts working when it wants to. Have been fighting with this non-stop all week doing every single trouble shooter in the book repeatedly. The technology is NOT ready yet for this. Real bummer

You should NOT have to do all that. For this to become mainstream and become more successful, it must be effortless plug and play. Shouldn't need a degree or years of tech experience to use this thing.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?