cancel
Showing results for 
Search instead for 
Did you mean: 

New Q3 doesn’t show up as device on PC

bacontricks.2024
Honored Guest

Hi, all! Plugging in my new Q3 to PC neither pops up a permission window in the headset asking if it’s ok, nor does it show up as a device on the PC. Following other comments on forums, Do not disturb is not on, my usb 3 cable works in that the headset is successfully connected to SideQuest on my PC (but I’m getting that path argument must be type string error message for synthriderz), and going into setting > developer does not have a USB Connection Dialog option. Rebooted PC and restarted Q3. 
Help?  Please 😊

3 REPLIES 3

MetaQuestSupport
Community Manager
Community Manager

Hey there. @bacontricks.2024! Running into issues getting your computer to recognize your headset is never a good time as playing VR on your PC is great fun. In this case we would need more information about this situation, so if you can reach back out with the following information, we can take another look:

 

  • Are you trying to connect to a PC or laptop?
  • What GPU are you using in the computer you are connecting to?
  • Are you using any adapters for your cable? As removing them can make the connection work better.
  • Are you making sure to connect the device to a USB-C 3.0 port? Connecting to a 2.0 port can prevent the device from being detected properly. 

Please reach back out with this information and we will be happy to continue working with you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Thanks for your help!

 
So for some reason, after I unplugged and replugged in the usb 3 cable a couple times, the window (on the Questh asking if I should allow the connection flickered on a moment.  So I re-plugged it in a couple more times until the window actually showed up long enough I could click on it. I’ve repeated it twice since then and it worked both times just fine. 
 
I haven’t had trouble with that usb 3 cable before, but could my usb port be a little flaky? Does that happen?  My PC is about 1-½ yrs old.  But mfg standards during the pandemic seemed not as good.  
 
At any rate, I’m happy it works now, and thanks for your help!  Not aeeing the Quest as a device sent me down the path of trying to make sidequest work because originally I thought there wasn’t an easy way to access the quest directly, so I guess it forced me to learn something new!  (But if you have any suggestions about the “path argument must be of type string” error when Sidequest fails to write to the Quest, I am all ears’)

 

Hey there @bacontricks.2024, we thank you for the swift reply and providing us an update to the matter. We're happy to hear that you are able to enjoy using your headset while connected to your PC. With that being said, to answer your question presented, yes over time, the USB slot on our computers can lose proper connection to allow device to be seen. We suggest if you have the access to another PC or Laptop to test the connection to ensure the USB slot is the cause for the intermitted connection. We appreciate you for continuously being the most important part of our VR community. Please do not hesitate to reach back out to us if you have any further questions or concerns. Have a legendary rest of your

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?