cancel
Showing results forΒ 
Search instead forΒ 
Did you mean:Β 

New Quest 2 user here...pcvr stutter is still an issue it seems πŸ˜’

BoringEagle
Level 4

-3060ti, i7 12th gen, 64gb ram

Ive had a quest 2 for about a week. Familiar with and used other headsets in the past (friends/family). Was excited to have my own headset finally. So, the native quest apps and environment are fine and smooth. BUT the moment I go into Oculus link/airlink i get these intermittent microstutters every time I move or turn my head. Ive tried every workaround i could find on the interwebs and nothing has removed/fixed the frequent movement/tracking stutter. My rig exceeds the specs and my router/internet is fine, but the oculus app doesnt want to play nice with steam vr, particularly with HL Alyx. The stutter/frame jump issue is hard to look at and making my experience terrible. After reading many posts, forums and articles on the subject I find its very common apparently? Many have said its actually gotten worse with updates. The fact that these intermittent stutter issues were apparently better or non-existent for the very same people in previous versions clearly indicates a software/update issue rather than a hardware or setup issue. Im inclined to believe its software side and recent updates have broken something that was working previously. If I cant get this figured out within 2 weeks (return period), i will fix the issue myself, by returning my Quest to where I bought it and getting a reverb or index! 

24 REPLIES 24

NumbrOneDad
Level 4

This is the worst it’s ever been. The v46 update introduced link-breaking runtime errors. It’s literally unplayable when you load up link. They had/have (depends if it shows for you or not) a SLIGHT fix in the PTC under the beta tab in pc client, seemed to have helped it at least run for the most part (stutters and hiccups still occurred but ghosting was fixed and no frame drops other than the rhythmic every 5-6 sec ). I can’t get access to that build anymore for some reason, swapped back and forth no problem yesterday but it started defaulting back to v46 today. Anyway, it was working perfectly before w no stutters but the past two updates have been sh*tty with no QC or provisioning. Just slapped together some code and failed to test it. Had they tested, they would have seen the issue firsthand. Either way, poor decisions from those working on whatever bull**** spaghetti code is going on these past two months. 

BoringEagle
Level 4

oof. Looks like i picked a bad time to jump in. Just updated nvidia drivers to most recent release and joined ptc beta.  Will try to jam later tonight  to see if problem persists or any improvement. Not optimistic from what im hearing on forums tho. sigh 😩 Sidenote, amazing how many bizarre workarounds exist for the issue; from audio output changes to leaving the debug console window open, to changing a bunch of graphics hardware settings.  Seems outrageous to me. Its as if Q and A doesnt exist anymore and the end user/customer has to guess how to fix the product!

If you can go to notifications on the pc client, click the notification for the download/update, and if it says β€œno information available about this update” then you will be on (what’s assumed to be) a small patch fix for the MAJOR stutter/ghost issue but not the entire issue. At least it’s playable that way (steamvr was fine, boneworks through oculus store was NOT). If it says β€œwhat’s new” and β€œv46 or oculus dash 1.39.1” or whatever then you’re stuck w the crapshoot that is the oculus platform rn. Either way, I’m sorry about your timing on this one. It’s not your fault, it’s a really enticing headset. I’ve loved it for the most part, but times like these make me feel like an absolute tool for buying into the belief that they’d give a sh*t about offering a playable experience for your money. 

Soooo, after updating the nvidia drivers and opting into the ptc beta, i tried to play some half life alyx tonight and sadly issue remains totally unchanged. Sent log files to support. We will see if they can at least glean some info from the logs. I will say it seems like the airlink has the "potential" to work smoothly, but there is clearly something amiss in the software side of things. Again, the hardware definitely meets req'd specs. My internet and bandwidth also meet spec. You would think as long as you "meet specs" on all criteria, it would be fairly plug and play. Guess not! Very disappointed. That all said I have about 2 weeks to get this situation hopefully resolved, otherwise i will return the device where i got it before the return window closes. I'll use the $ for another headset with more reliability. Index kit is on sale for $999 atm, might do that instead. I only chose the quest 2 for the wireless option, as cords tend to wear and get tangled easily from my experience, if not outright yanked out on accident...repeatedly.  

So I went out on a limb and got virtual desktop on sale and guess what. Its performance playing pcvr through wireless is great compared to the airlink/link app. Night and day. This essentially proves the issue is not my network or the device (quest native stuff works fine) but rather the oculus airlink software. It simply struggles with tracking/movement for some reason lately with stuttering and glitching. The vd app does the same job 1000x better. I was told by support to use the "route this" app to discover network issues and of course, my network is fine. I've tried all other workarounds recommended, settings, etc and it seems airlink is simply not up to the task of wireless pcvr without stutter. it's an issue the airlink devs are solely going to have to figure out on their end. Perhaps they can get advice from the people that made virtual desktop! Virtual desktop is the only reason I may not return this device (I was ready to) as I can play pcvr now, and do so smoothly, with their third party app. Amazing that a couple guys made the virtual desktop app with little support, and it functions better than a billion dollar companies product!

Roky360
Level 4

Hey there,

I had the frame skip issue for around 13 months would you mind trying something for me.

Go to Settings/Graphic Settings/ on browse add in these 4.exe files

OVRRedir

OVRServer_64x

OVRServiceLauncher

OculusClient

Set the 4 files above via Settings/Graphic Settings/Browse

Now add all 4.exe files from the Oculus folder, you will have to find these in there.

In folders Program Files/oculus-client - OculusClient.exe

Program Files/oculus-runtime -

OVRRedir

OVRServer_x64

OVRServiceLauncher

Once added in graphic settings manualy go to options and set graphic preferences to

High Performance

GPU: Nvidia RTX ****

Save

Also now you can head to the settings in SteamVR and open advanced settings tab/developer i believe and set runtime to Oculus.

Give that a try and let me know how that goes.

Also in display drop down to 1080p and 60hz

Could you let me know if that helped.

I had a RTX3080 and a different rig with a RTX3080ti both stuttered until i did this after 13 months of trying to figure what the issue was.

Thanks

Roky360
Level 4

I try it, but didn't help me.

TheAllStarr
Level 2

The only fix I have found was to use 120 hz with VD. While I haven't tested with link, it has fixed my stuttering with Virtual Desktop. I had tried everything. I noticed that when checking all my metrics, they were perfect. My frame time response was amazing, router was literally 4 ft away hitting less than 10ms response time at 866mbps, no network drops and plenty of headroom on my GPU and CPU. Yet, within the headset, I could see weird lag and stretching. It almost looked like async but async was off.

Randomly decided to turn 120 hz on my Quest on and then on Virtual Desktop and boom, smooth as butter. There are still dips here and there but it's like night and day in terms of stability. The weird async looking stretching is gone.