cancel
Showing results for 
Search instead for 
Did you mean: 

New meta account device code not working

PTGGamer7114AB
Level 3

I went to play an online game a few days ago, and it kicked me out telling me to go make a meta account. i do all the steps to make on, and then it tells me to go to www.meta.com/device to put in the code it prompted me with. I put in the code, and it said an error occurred, Generate new device code. Now i tried again a few days later, after that error happening many many times, and now it says the account I'm using does not match my purchases and stuff on my oculus account, saying I'm using a different account, BUT IM NOT. i really need help because I can't play any games.

1 ACCEPTED SOLUTION

Accepted Solutions

Some users are still experiencing an issue with their device code not working, however, a lot of them have been able to resolve it by following a few steps I'll outline below:

 

1. Make sure you are trying to set up the device with the same account you're logged into on the app (we need to make sure your device is listed on the correct account). You can check this by going here: https://secure.oculus.com/my/devices

2. You can go to this site if you need to log out: auth.meta.com/settings

3. Then you can log in with the correct account, or start over using a different login by factoring resetting your headset

 

Hopefully that helps! 

View solution in original post

74 REPLIES 74

shane.tyas
Level 3

having same problem right now, i am good following instructions and updated the quest 2 first, made the meta account etc. figured it was all done and dusted, shut down quest, restarted, and now i cant get into anything, keep trying the code in device and says code expired over and over on a loop and im punching the code in pretty quick, tried turning quest on and off a few times. i think ill try a new browser.

 

edit: tried the code activation using CHROME instead of FIREFOX.. worked. if you are using FIREFOX try CHROME instead. device will restart after you confirm the code, you know are good to go after that.

 

MetaQuestSupport
Community Manager
Community Manager

Hey there! We hate hearing that you are experiencing that. We'd love to help you.

 

Can you please uninstall the Oculus app on the smart phone and PC and then reinstall it. Did you also go to meta.com/setup?

pham.hai.nam
Level 2

I have the same problem too. It keeps asking me to enter code in a mobile or pc browser. I tried both from my phone (android) and my macbook, with different browsers (edge, chrome, safari). After entering the code, in the Quest 2 it said Account Linked for a few second and then follow up by "an error has occurred, generate new device code", and that is looped endlessly.

FunkyBlackSanta
Level 2

Hi, I'm having the exact same problem, keeps telling me to input a different code and cannot get past that screen. Tried on both pc and mobile, no luck. However, my meta account is apparently active and knows it's linked to my headset, yet headset itself won't let me progress any further. Please advise as I currently cannot use the headset and it wasn't cheap!

Kelsonk1023
Level 2

This was happening to me too, I think it had something to do with the fact that I had a FB account and a seperate Oculus account. Try logging out of meta on your browser and relogging in with your Oculus account if you have one. 

smithes75
Level 3

I had to do a factory reset on the headset. It worked and I no longer get the long code or the error afterwards. 

yes i went to that website, and i completed all the steps.

trying it right now