cancel
Showing results for 
Search instead for 
Did you mean: 

No audio when using Oculus Link

Nalin
Protege
I have no audio on my Quest headset when using Oculus Link.  These are all the things I have tried to resolve the issue:
  • Reboot PC and/or Quest and plugged things back in in many different orders.
  • Restarted the Oculus service.
  • Tried different USB ports.
  • Tried different USB cables.
  • Tried both an active and a passive extender.
  • Tried throwing a USB 3 hub into the mix just because, both as the first part of the chain and as the second part.
  • Tried with headphones plugged into the Quest and with them removed.
  • Tried toggling all the options related to sound that I could find within the software (Devices > Quest and Touch, all those sound options).
  • Repaired / reinstalled Oculus software.
  • Uninstalled Virtual Desktop Streamer app and its audio driver.
  • Changed my desktop speakers from 5.1 to stereo.
  • Attempted setting every single audio output device as default in Windows.
  • Plugged in my CV1, went through the setup, and then tried piping audio through the Oculus Rift Headphones audio output adapter.
  • Reinstalled oculus-driver.exe.
  • Opened a ticket with Oculus Support (they told me they won't support beta software, lol)
Is there anybody with the same issue who found a solution?  Or at this point is my only bet to wait a year until it stops being beta and Oculus Support actually tries to help?
EDIT: I finally got it working after uninstalling the NVIDIA HD Audio driver.
  1. On your keyboard, press Win+X > Select "Device Manager"
  2. Open up the "Sound, video and game controllers" node.
  3. Right click the NVIDIA High Definition Audio driver and choose "Uninstall device".

1 ACCEPTED SOLUTION

Accepted Solutions

TheLegend27
Meta Quest Support
Meta Quest Support

Hey everyone! It looks like this thread is still getting some traffic from the occasional user, so I'm going to go ahead and lock it. This looks like an issue that was present in the early days—dating back to V13. To avoid floating old threads with outdated information, I highly recommend creating a new thread detailing the new issue, so that our teams can monitor new emerging issues caused by recent releases—or other leading causes. I also recommend taking a look with the native search function to find a more recent existing thread with the same issue.

Technology, at a certain level of sophistication, is indistinguishable from magic. - some wise guy or something probably

View solution in original post

116 REPLIES 116

Protocol7
Heroic Explorer
Does the Quest appear as an audio output device in Windows?

Nalin
Protege
It does not.  I'm not sure if it is supposed to.  I've heard at least one person say they don't have it.

Anonymous
Not applicable
Cas from Cas and Chary had the same issue when just using a usb-c cable, but after connecting a 5m Cable Creations active usb 3.0 cable on top of that, she had audio. Not sure why.

https://www.youtube.com/watch?v=qqz065QERsw

Nalin
Protege
I used that exact same extender cable that she uses in the video with a 3 foot Anker cable and got no audio.  I also tried using the 3 foot cable by itself and also got no audio.

Anonymous
Not applicable
You have audio with the CV1 though, correct?

vargablood
Expert Protege
i have audio with the anker usbc cable, only microphone seems to be not supportet at the moment. But i had to activate it by enabling the Audio switch in the oculus pc software under quest device settings.

Nalin
Protege
Yes, I have audio with the CV1 with no problem.

Anonymous
Not applicable
Sounds like a settings issue then. Maybe the same as what vargablood had to do, enabling the Audio switch under the Quest settings in Oculus Home(?).

CrixUK
Explorer
Try selecting a different audio output (click on speaker icon in taskbar).
for some strange reason selecting my 2d monitor as audio output sent it to the quest.
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?