Showing results for 
Search instead for 
Did you mean: 

No connection to Oculus App with Orange Light inside headset

Level 2

I've been having this issue for months now and have been completely unable to use my headset because of it. I will plug my Rift S into the correct ports that have worked in the past, but the only thing I will receive is an orange/red light (I am colorblind so its a little hard to tell but I think it's orange) inside the headset with no green checks in the Oculus Rift S detection screen and only spinning circles. I have attached some images below.

My pc will recognize the Rift S, changing my audio devices to the Rift S as well as my microphone input, but still nothing will show on the actual Oculus app itself. This makes me completely unable to do anything as I'm just stuck on a black display with an orange light that can still have audio come through and is recognized by my pc. I've been messaging support for a few weeks now but they have been zero help whatsoever. I have tried to use a separate pc entirely to use the Rift S, but the same issue occurs. As for the controllers, i will press the buttons on them, they will flash 3 times, then turn off. they also do not connect. My cables are not damaged at all and work perfectly fine. I have tried so many fixes that I am very close to just giving it up and calling it quits.

All of my drivers are up to date to my knowledge

I've tried a fresh windows installation and a hard computer reset

I've tried other 3.0 ports and display ports, same issue everywhere

Orange light in the headsetOrange light in the headsetNo connection to oculus appNo connection to oculus app


Community Manager
Community Manager

Hey there Bckpack12! Sounds like this has been a pretty confusing issue for you. We're happy to help get your Rift S back in working order! The light is indeed orange, which means the headset isn't connecting for some reason. We have troubleshooting steps available for this exact issue right here and if those steps don't help, you can always reach out to our support team here for some extra assistance. We look forward to getting you back in the game!

Level 2

I have been talking to support for weeks now, the team behind it is absolutely terrible. I came here to talk to people who don't send automated messages that somehow have grammatical errors and provide no actual help.

Level 2

same issue and no way to resolve it

Hello there VRKnoxNZ we noticed that your reporting that you are having No connection to Oculus App with Orange Light inside headset we definitely understand you would like to get back to your VR experience.

  • Does you headset turn on and if so does your screen inside the headset turn on or is it a black screen?
  • Have you tried a Factory Reset? If not here is the details on how to do so below.

However, we want to make sure your Cloud Backup is on and you can check that by clicking here that way your data (if any) is saved! Once the Cloud Backup is on we go ahead and perform the Factory Reset.

To perform a factory reset using the headset:

  1. Turn off your headset.
  2. Hold the power and volume (-) button on your headset down simultaneously until the boot screen loads on your headset.
  3. Use the volume buttons on your headset to highlight Factory Reset and press the power button.
  4. Use the volume buttons on your headset to highlight Yes and press the power button.

Let us know if this helps.

Level 2

oculus support are you dumb there is no power button on a rift s 

Having the same issue and still no power button even after updating firmware 🙂