cancel
Showing results for 
Search instead for 
Did you mean: 

(Not Resolved) Known Issue - Quest PCVR streaming micro lags and stutter esp. when moving head

acreed11
Protege

Hi team,

I'm getting micro lags and stutter in Airlink on my Quest 3 (EU/UK), esp. when moving my head. In the Oculus debug overlay this causes brief spikes in transmit/decode, fps drops and visible stuttering. The issue is not present on my Quest Pro with otherwise identical settings - see below screenshots to illustrate.

Few more details:
- Issue is not present on Quest Pro with same settings on HMD, router and PC (using same res)
- Issue is worse at higher bitrates, esp. >200mbps, but still present <200mbps
- Issue is unrelated to PC/game latencies (CPU, GPU, Queue each <5ms)
- Stutters/lags are intermittent (every 10-20 seconds) when not moving but happen immediately and reproducibly when moving the head to either side or especially looking downwards (i.e. on any bigger headset movements)
- Wifi 6E router (TP Link AXE75 EU/UK)
- EDIT: exact same issue with Asus RT-AXE7800 (EU/UK) wifi 6e router
- Connection shows as 2,400mbps
- Airlink codec H264 (but same on other codecs)
- I've attempted factory resetting, installing latest drivers
- Updated to v62 and latest Quest Link desktop version (I can see the 120hz option for my Q3)
- EDIT: Ordered a separate Quest 3 for testing: presents the exact same issue

-EDIT: Same issue on 5ghz 802.11ax 160mhz BUT switching to 802.11ac (!) completely fixed the issue. I cant test this on 6ghz but looks like 802.11ax or something related to how q3 implements it is the culprit

As the issue is worse the higher the bitrate and not present on Q Pro with otherwise same settings, I suspect it's related to the below known Wifi issues - but opening a new thread as instructed. 
https://communityforums.atmeta.com/t5/Get-Help/Known-Isssue-Unstable-wifi-coverage-with-Quest-3-on-s...

Best,
JensQ3Q3QProQPro

Updates:
- Tried separate router: exact same issue with Asus RT-AXE7800 wifi 6e router
- Ordered a separate Quest 3: exact same issue on both routers

-Same issue on 5ghz 802.11ax 160mhz BUT switching to 802.11ac (!) completely fixed the issue. I cant test this on 6ghz but looks like 802.11ax or something related to how q3 implements it is the culprit

242 REPLIES 242

Babinok
Expert Protege

Hi, I recently also had the same problem with Airlink and other streamers working. Regardless of the bitrate settings of the transmitted image, there are constant stutters when you move your hand or move your head. Even with a minimum bitrate of 10MB and with all codec options on the graphs, the transport network graph and decoding graph behave inadequately during movements. I recorded all the details on video.

My hardware configuration:
CPU type: AMD Ryzen 7 5700X, 4850 MHz (48.5 x 100)
Motherboard: Asus TUF Gaming B550-Plus
System memory: Two Corsair Vengeance LPX CMK32GX4M2D3600C18 16 GB DDR4-3600 sticks
Video adapter NVIDIA GeForce RTX 3080 (12 GB)
Router: Keenetic Giga KN-1011 (The router has a separate 5GHz band for the quest 3 configured in ax mode.)

While solving the problem, the system was reinstalled, various router settings were tried, a different router, cables and many system settings were tried. When connected via a regular USB cable via quest link, there are no problems, the gameplay is smooth.

Videos:

https://youtu.be/6fVoXgmV6Hs?si=Kw5mKCcTFITDjKcL

https://youtu.be/w5J0j9xUtnU?si=ZDizaXPC6oVZR4TQ

https://youtu.be/51kR652Rns8?si=QjD1G3CYVkwqbnpT

https://youtu.be/OtKbpI6upOg?si=k9DMh-AZgLcP1egm

https://youtu.be/N2QxHmiZ5nM?si=yKeNlq89aEZLKznq

I tested the speed of the router using iperf3 with Quest 3 and iPhone Xs Max- the results are visible immediately. Quest 3 has constant drawdowns from time to time.

Снимок экрана 2024-02-25 202032.png

Babinok
Expert Protege

del

TheAntiSocializer
Meta Quest Support
Meta Quest Support

[NOT A SOLUTION, THIS IS NOT RESOLVED] - Simply marking for visibility

Hey everyone! Thank you so much for the information you've all been providing. Our team has been following this thread and have also flagged it internally for further review.

To make sure we can get the right information to our team, can everyone please provide the following:

  1. What's the full version number of your headset? (62.0.0.####### or likewise)
    • Quick Settings > System > Software Update
  2. What's the full version number of your PC app? (62.0.0.####### or likewise)
    • General > Scroll down to the bottom of the page.
  3. Is your PC app on PTC?
  4. Are you enrolled in Quest PTC?
  5. Any potential workarounds?
  6. Which headset is everyone using? Is this only happening with the Quest 3 currently, or is anyone experiencing the same thing on their Quest 2?
  7. Which router are you using? (Brand & Model)
  8. What protocol is your router?
    • 802.11ac, 802.11ax, 802.11be, etc.
  9. What bitrate is your Air Link currently set to?
    1. Do you have any other tweaked settings within Oculus Debug Tool? If so, what settings?
  10. What are your system specifications? Do they meet the Meta Quest Link requirements?

Along with this if you have not already done so, I would suggest reaching out to the support team via email so that they can gather a copy of your logs as well.

If you have already reached out to support and provided your logs, please PM @MetaQuestSupport with your case number.

Sometimes it's okay to be a little Bing Chilling

  1. What's the full version number of your headset? (62.0.0.####### or likewise)
    • Quick Settings > System > Software Update  > 62.0.0.260.343.566123828
  2. What's the full version number of your PC app? (62.0.0.####### or likewise)
    • General > Scroll down to the bottom of the page. Meta Link App > Version 62.0.0.235.346 (62.0.0.235.346)
  3. Is your PC app on PTC? > NO
  4. Are you enrolled in Quest PTC?  > NO
  5. Any potential workarounds? NO
  6. Which headset is everyone using? Is this only happening with the Quest 3 currently, or is anyone experiencing the same thing on their Quest 2? > Quest 3
  7. Which router are you using? (Brand & Model) > Archer AX75 | AX5400 
  8. What protocol is your router?
    • 802.11ac, 802.11ax, 802.11be, etc.  
      > Mode:
      802.11ax only - WiFi6e - 6Ghz
  9. What bitrate is your Air Link currently set to?  > 400Mbps (H.264)
    1. Do you have any other tweaked settings within Oculus Debug Tool? If so, what settings? NO
  10. What are your system specifications? Do they meet the Meta Quest Link requirements?

AMD 5800X3D / RTX3080 / 32GB RAM / win11 PRO.

Apologies. Didn't mean to reply to your post specifically. I don't agree with marking the thread as answered. I think we're yet to receive a proper response let alone a solution. I'm very concerned about such a core feature being broken for so long.

Agreed, this issue is far from "solved"

Hey @Galatoni and @SciFi_Steve_69! Trust me, I completely understand your concern and I wanted to explain a bit more on the 'marking as resolved' portion. I would love to be able to pin the message to the top of the thread so it doesn't get lost with any new comments that come in. With that being said, we don't currently have the option to be able to do that on the forums, so marking as a solution is our best option.

Sometimes it's okay to be a little Bing Chilling

Babinok
Expert Protege
  1. What's the full version number of your headset? (62.0.0.####### or likewise)
    • Quick Settings > System > Software Update - 62.0.0.260.343.566123828
  2. What's the full version number of your PC app? (62.0.0.####### or likewise)
    • General > Scroll down to the bottom of the page. - Meta Link App Version 62.0.0.235.346 (62.0.0.235.346)
  3. Is your PC app on PTC? - No
  4. Are you enrolled in Quest PTC? - No
  5. Any potential workarounds? - No
  6. Which headset is everyone using? Is this only happening with the Quest 3 currently, or is anyone experiencing the same thing on their Quest 2? - Quest 3
  7. Which router are you using? (Brand & Model) - Keenetic Giga KN-1011
  8. What protocol is your router?
    • 802.11ac, 802.11ax, 802.11be, etc. - 802.11ac (less stuttering) 802.11ax (more stutters)
  9. What bitrate is your Air Link currently set to? - 10Mbps (H.264)
    1. Do you have any other tweaked settings within Oculus Debug Tool? If so, what settings? - No
  10. What are your system specifications? Do they meet the Meta Quest Link requirements?AMD Ryzen 7 5700X, Asus TUF Gaming B550-Plus, Corsair VENGEANCE LPX DDR4 RAM 32GB (2x16GB), NVIDIA GeForce RTX 3080 (12 GB), Windows 11 Pro (23H2). Yes, they meet.

I think this option will only confuse people who are looking for help on this topic and will not be able to find it after seeing the encouraging status.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?