cancel
Showing results for 
Search instead for 
Did you mean: 

(Not Resolved) Known Issue - Quest PCVR streaming micro lags and stutter esp. when moving head

acreed11
Protege

Hi team,

I'm getting micro lags and stutter in Airlink on my Quest 3 (EU/UK), esp. when moving my head. In the Oculus debug overlay this causes brief spikes in transmit/decode, fps drops and visible stuttering. The issue is not present on my Quest Pro with otherwise identical settings - see below screenshots to illustrate.

Few more details:
- Issue is not present on Quest Pro with same settings on HMD, router and PC (using same res)
- Issue is worse at higher bitrates, esp. >200mbps, but still present <200mbps
- Issue is unrelated to PC/game latencies (CPU, GPU, Queue each <5ms)
- Stutters/lags are intermittent (every 10-20 seconds) when not moving but happen immediately and reproducibly when moving the head to either side or especially looking downwards (i.e. on any bigger headset movements)
- Wifi 6E router (TP Link AXE75 EU/UK)
- EDIT: exact same issue with Asus RT-AXE7800 (EU/UK) wifi 6e router
- Connection shows as 2,400mbps
- Airlink codec H264 (but same on other codecs)
- I've attempted factory resetting, installing latest drivers
- Updated to v62 and latest Quest Link desktop version (I can see the 120hz option for my Q3)
- EDIT: Ordered a separate Quest 3 for testing: presents the exact same issue

-EDIT: Same issue on 5ghz 802.11ax 160mhz BUT switching to 802.11ac (!) completely fixed the issue. I cant test this on 6ghz but looks like 802.11ax or something related to how q3 implements it is the culprit

As the issue is worse the higher the bitrate and not present on Q Pro with otherwise same settings, I suspect it's related to the below known Wifi issues - but opening a new thread as instructed. 
https://communityforums.atmeta.com/t5/Get-Help/Known-Isssue-Unstable-wifi-coverage-with-Quest-3-on-s...

Best,
JensQ3Q3QProQPro

Updates:
- Tried separate router: exact same issue with Asus RT-AXE7800 wifi 6e router
- Ordered a separate Quest 3: exact same issue on both routers

-Same issue on 5ghz 802.11ax 160mhz BUT switching to 802.11ac (!) completely fixed the issue. I cant test this on 6ghz but looks like 802.11ax or something related to how q3 implements it is the culprit

263 REPLIES 263

Thanks for chiming in but this is a different issue unrelated to this thread you have in your videos. Please seek support for this separately, it's unrelated to this.

  1. What's the full version number of your headset? 62.0.0.273.343.570372063
  2. What's the full version number of your PC app? 62.0.0.235.346 (I use Virtual Desktop)
  3. Is your PC app on PTC? Nope
  4. Are you enrolled in Quest PTC? Nope
  5. Any potential workarounds? Nope
  6. Which headset is everyone using? Is this only happening with the Quest 3 currently, or is anyone experiencing the same thing on their Quest 2? Both Quest 3 and Quest 2
  7. Which router are you using? Tp link AXE75, and Asus RT-arch18
  8. What protocol is your router?  802.11axe, 802.11ac
  9. What bitrate is your Air Link currently set to? All bitrates, I use Virtual Desktop
    1. Do you have any other tweaked settings within Oculus Debug Tool? If so, what settings?  Nope
  10. What are your system specifications? Do they meet the Meta Quest Link requirements?  4090, 13900K, 64 GB

Same issues.  Please fix this. Worked well some time ago. Now it is unusable.

How do I return my quest 3 under warranty? I need to actually be a able to use the 4090, 13900K Pc and new computer that I built to play pcvr.  This has been going on forever, as per VirtualOmnipresence's definitive video. I need to buy a quest pro, right? 

SciFi_Steve_69
Protege

So, apparently v63 is now being released. No mention of bug fixes in the release notes, just a list of trivial things added, Quest Cash, lying down mode (unless you're on Quest 3, thanks for excluding your latest headset Meta).
Is anyone else losing faith in this product line? Nothing seems to be getting fixed, there's no official (valid) bug reporting and more importantly tracking of reported bugs like you would see on Github. 

I'm guessing this WiFi issue will persist into v63, can anyone confirm/deny here please once they have it?

TheJ0rma
Protege

v63 seems a bit better than v62 but it still has some stutters

DeltvV
Honored Guest

I'm getting pretty much the exact same issue (USA). When I move my head, I get "lag" or "micro-stutter". Everything works perfectly fine when connected via Link cable. 120 FPS @ 120 Hz refresh rate, maximum 1.7x render resolution, Encode Bitrate cranked out to ~900 Mbps via Debug tool; not a single hitch or lag spike; picture looks flawless; GPU barely reaches 60% utilization; no complaints.

However, when connected to Air Link over Wi-Fi, that is when I start to experience these problems when physically looking around with the headset:

Encode/Xfer/Decode(ms) - Green line spikes way past the chart, the blue line usually spikes with green line although to a lesser degree. During this spike, the Frame Rate (Hz) dips a little bit, from solid 120 FPS to ~ 90 FPS, but it feels much more choppy than just a frame dip.

I spent an entire day testing, mixing and matching different Wi-Fi bands, frequencies, channels, and can fairly say that the stutters get a bit better at the higher frequencies/ channels like 6 GHz: 160 Hz - 161, 157, 221, but still very noticeable during head movement. The router is in direct line of sight of my headset, ~ 3 - 6 feet away.

My equipment:

Quest 3 Version: 62.00.273.343.570372087

Quest 3 Runtime Version: 62.0.0.269.341.570372063

Quest 3 OS Version: SQ3A.220605.009.A1

Meta Quest Oculus App (Windows 11): Meta Link App Version 62.0.0.235.346 (62.0.0.235.346)

Router: TP-Link Tri-Band BE9300 WiFi7 Router: Archer BE550 (2.5G PC wired directly into router)

I've tried using Steam Link APP, (not very familiar with it), and it seems to not stutter but instead the movement "feels" bad; like there's some input lag or something. I just want the wireless Air Link to work half as good as wired Link cable.

Does anyone happen to know if this is affecting all Quest 3's? I'm still within my return period, and I'm wondering if this is faulty wireless hardware on a certain batch of units that I should try replacing. If I missed anything, please let me know, if you have any suggestions, please let me know.

I think you should return the headset back to the store, because technical support is not going to solve the problem in any way. I have been communicating with technical support for a long time and all the advice received from them consists of suggestions to reinstall the oculus software. Before this, I wrote to them several times that I had reinstalled Windows with all the software.

I would believe the issue is now with their Dev, and tech support is here to just grab info / communicate. (I work for tech support escalations). 

And Dev. Will take their sweet time. They have to test it across diff hw / soft specs. And this issue has alot of moving parts.

 

Can't say for sure if it's all Q3s, but all three of mine are affected. The Quest 2 we also have is unaffected.

GODforYOU123
Honored Guest

Some notes which can help to solve the problem:
At first, I triggered that lags/stutters by fast headset's movements (this method is far from perfect for many reasons). Then I have realised that stutters can be triggered even y tapping by headset. Every time I tapped by headset - I saw huge spike on the graph(network+decoding). Then I guessed that my hand can be an obsticle (or somewhat similar) for wifi connection. And I ve tried to detect the place on headset which was the most sensetive to my hands. This place was a topside of headset. Every time I tap or even slide (fast enough) by top of headset - I see that spike on the graph.
IThis happens only with airlink. VD has not that problem.
My rouyter is mercusys mr80x, i seat from 0.5-1m distance from router and have problems with airlink at 100, 300, 500, 800mbits bitrate.

Feature "Passthrough mode by double-tapping headset" can cause this problem, but I haven't noticed any changes with this setting on/off.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?