cancel
Showing results for 
Search instead for 
Did you mean: 

(Not Resolved) Known Issue - Quest PCVR streaming micro lags and stutter esp. when moving head

acreed11
Protege

Hi team,

I'm getting micro lags and stutter in Airlink on my Quest 3 (EU/UK), esp. when moving my head. In the Oculus debug overlay this causes brief spikes in transmit/decode, fps drops and visible stuttering. The issue is not present on my Quest Pro with otherwise identical settings - see below screenshots to illustrate.

Few more details:
- Issue is not present on Quest Pro with same settings on HMD, router and PC (using same res)
- Issue is worse at higher bitrates, esp. >200mbps, but still present <200mbps
- Issue is unrelated to PC/game latencies (CPU, GPU, Queue each <5ms)
- Stutters/lags are intermittent (every 10-20 seconds) when not moving but happen immediately and reproducibly when moving the head to either side or especially looking downwards (i.e. on any bigger headset movements)
- Wifi 6E router (TP Link AXE75 EU/UK)
- EDIT: exact same issue with Asus RT-AXE7800 (EU/UK) wifi 6e router
- Connection shows as 2,400mbps
- Airlink codec H264 (but same on other codecs)
- I've attempted factory resetting, installing latest drivers
- Updated to v62 and latest Quest Link desktop version (I can see the 120hz option for my Q3)
- EDIT: Ordered a separate Quest 3 for testing: presents the exact same issue

-EDIT: Same issue on 5ghz 802.11ax 160mhz BUT switching to 802.11ac (!) completely fixed the issue. I cant test this on 6ghz but looks like 802.11ax or something related to how q3 implements it is the culprit

As the issue is worse the higher the bitrate and not present on Q Pro with otherwise same settings, I suspect it's related to the below known Wifi issues - but opening a new thread as instructed. 
https://communityforums.atmeta.com/t5/Get-Help/Known-Isssue-Unstable-wifi-coverage-with-Quest-3-on-s...

Best,
JensQ3Q3QProQPro

Updates:
- Tried separate router: exact same issue with Asus RT-AXE7800 wifi 6e router
- Ordered a separate Quest 3: exact same issue on both routers

-Same issue on 5ghz 802.11ax 160mhz BUT switching to 802.11ac (!) completely fixed the issue. I cant test this on 6ghz but looks like 802.11ax or something related to how q3 implements it is the culprit

286 REPLIES 286

Based on my observations, the problem is not only with the airlink. The problem is related to incorrect tracking of the headset itself and appears under a certain load on the headset, possibly under load on the decoder. Even native games have this problem to varying degrees. This problem exists even in the headset's home environment. But this problem does not exist when using a USB cable with PCVR games. This problem is also observed to an even more pronounced degree when using VD and steamlink streamers. I strongly recommend that you pass this information on to your technicians so that they can move in the right direction to resolve the issue before our devices reach the end of their life cycle. I haven't been able to use the device I bought for half a year now.

Thank you for keeping up with this! We eagerly wait for a fix

Ferrous_Wolf
Honored Guest

Just got My quest 3 and I was using it via cable and that worked fine. First time I try it on air link it was completely unplayable. Threw my quest 2 on and tried the air link and that worked perfect. Both had been updated to V66. 

Went nuts trying to figure it out until in the air link settings I turned the resolution down to the minimum and I could play fine. All that money for An upgraded headset and to use Airlink the visuals actually look worse than the quest two… Please fix soon.

Zombieyoda
Explorer

Not counting my chickens yet but as of yesterday(12/06/2024) all my frame drops have disappeared for pcvr via VD, not tried steam vr as i dont use it, however beat saber is now playable currently at 90fps with no lag or stutter.

Can't say for sure what has fixed it for me (so far) as there were updates to steam vr (V 2.6) & VD (V 1.32.5) , also i hard reset my router at the same time as well as configured my mesh system to use WAN/LAN backhaul instead of wifi. Since all this , i now have totally smooth gameplay with no random 20-30 FPS frame drops.

 

My PC:
CPU - Intel 12700k
GPU - Nvidia 4070 ti Super
Ram 32GB ddr4 @3200MT
Router - Asus ROG Rapture GT-BE98
Meta Quest 3 128GB connected via WIFI 6

IRefuseToLose
Explorer

**bleep**, this driving me crazy! I purchased Quest 3 especially to play PCVR wireless so i bought 2400mbps router with it and every time i move my head i get stuttering. The only setting that gets rid of stuttering was at 72fps. Even 80Hz creates a significant stuttering.

I tried to play directly through SteamVr software without installing anything from Oculus.

I blamed Steam at first but then i tried to play wireless. 

I installed Oculus software to play by wire and manage to play Half-Life: Alyx at 90fps and dynamic resolution with no lags at all!

I started to blame my router so i bought more expensive model. At my despair, it did not fix anything! Then i kinda pushed to all in, and bought 250$ router because i did not know what else could be a problem. IT STILL JUST THE SAME as with previous two routers! 

I thought that my item was defected but i can finally see that a lot of users have this problem.

My current PCVR experience is a dog**bleep**! I really love My Quest 3 but i can not enjoy what i bought it for. Please fix this issue, i did not want to sit with wire while i bought it to play wirelessly with a good router.

Routers that i tried: TPLink archer ax53, Asus ax57, Asus ax86u. I tried every possible combination of settings ac/ax, 80/160Hz, channel number but it wont matter! It is definitely not a router problem!

I have latest version on my headset and Oculus PC Software.

i can agree that i see kinda the same lag when i make a screenshot or start/pause video recording or when there is something happening in the background so it just getting laggy and maybe approximation of positioning gets broken.

At the same time, i can see the picture with no lags if i did not move! That means that it transfers the picture precisely clear but lags only when it tries to define my current positioning. 

This should be definitely on Quest 3 hardware/software side since it can not work properly under the load (but it works perfectly under the wired option somehow).

Also, from my observation, i can play with no lags directly via Steam Link + SteamVr software at 72Hz. Just by increasing it to 80Hz it starts to lag drastically! Any other setting in SteamVR does not do anything, but 72Hz fully fixed the issue for me.

Please try to set your fps to 72Hz in SteamVR (do not use Oculus software at all) and see if the issue gone. Yes, it totally sucks and i can not play in such kinda low fps in 2024 year since it supports almost two times more but it can help us solve the issue if there will be more feedback.

Should be noticed that Oculus states 72Hz to be recommended for Quest 3 in the Oculus settings. Seems like they know something about this issue so they might just staying quiet and leave us suffering with this issue for eternity if they can not fix it.

 

Tell your engineers they are geniuses. They even broke something that had somehow worked before. Now the airlink has stopped working altogether. The headset does not detect the computer. After following all the instructions from this topic, everything starts working, but only until the headset is rebooted for the first time and everything needs to be repeated again.

https://communityforums.atmeta.com/t5/Get-Help/Air-link-randomly-stopped-working/td-p/1069694#M22322...

Now I can’t even connect to my wifi using the standard method, I have to call up the old wifi interface and connect to the network there. Are you mocking your users on purpose?

PiEz
Explorer

Been pulling my hair out with the quest 3 since i got it.really bad stuttering,went through everything then found i had the same isuue as what alot of people are reporting here.the quest 3 is unplayable accross wifi with Tenda AXE5700 router in 6e - (ax) mode.If i connect to 5ghz - (an) mode at 160htz bitrate is reduced from 2400 to around 1700 but the stutters are gone.There is some problem with the quest 3 and 6e (ax).I hope they look into this so i can connect it back up onto the superior 6e wifi

Pantofli
Honored Guest

Hello Guys, I have this problem where I get Micro Lags and Stutters when moving my head. Another Thread also adressed a similar issue but I couldnt really get understand a fix when reading his post. For context, Im using a Link Cable and it says that its compatible, my PC is also above the minimum. Thank you.

xSkullzZ
Honored Guest

Hi, I've purchased a Meta Quest 3 today and I spent the whole day trying to setup it to play with my PC.

As standalone the Quest 3 is working flawlessly and I'm really happy how everything works. But when I tried to setup everything for playing with the PC everything fell down and escalate quickly into a disaster.

I've set up the AirLink with the WiFi (I was not aware that the Link Cable was not included in the box, that already for me sounds a bit cheap as an experience because I read that Quest 2 came with the cable. Thumbs down on that). The Schematic of my setup is desktop PC under the table with the router directly on top of the same table, and I'm playing at 1m from both of them. (LAN connected and WiFi6 compatible).

The Meta App was running good, no errors, no strange banners, nothing strange, I tested the Link connection, all green flags, I paired everything and started the AirLink.

The AirLink started without any kind of problem, but it started to get very laggy and with a lot of delay for both inputs and frame generation. I then reduced the resolution to the minimum (0.9x) and the bitrate to 10Mbps and everything started to work fine, even if the quality was very bad. But I was not caring for that at the moment, I just wanted to start playing and tweak that later.

I started Assetto Corsa (I bought this VR to race mainly), set the video settings and set to OpenVR. In the Meta App set as default for Runtime OpenXR. I start and get "Unable to Initialize VR". I then tried to follow multiple videos online but always getting the same error. I tried with Oculus VR but the game crashed. 

Then I thought, maybe it is a problem of the game because it is quite old and something may not work as expected, even though I played with RiftVR using my phone as an headset, but ok. So I went to Automobilista 2, more recent, with a really good VR support (as the community said online). I try to start it and my AirLink shows no thumbnail and no name "Loading ... "without any app name. I stop everything and I see Automobilista 2 in the app list, I try to open it again but still no thumbnail or app name and the game starts as normal on my monitor. The tracking works, I can see my mouse moving around when I move my head.

Then I try with an alternative method, SteamVR. Maybe I was skipping this step and it was required, but I noticed that nobody mentioned it online. I tried and I get that my GPU may be incompatible with their service.

My PC is:

  • AMD Ryzen 9 7950X3D
  • 64 GB RAM DDR5 6400MHz
  • Intel ARC A750

Then I started to see that in some old post about one year ago that ARC was not compatible, but that a banner would have appeared in my app immediately, so I want to hope that this is not a compatibility issue still, I would be very disappointed. Also because I saw that if I pay 20€ for Virtual Desktop 3rd party app I can run pretty much everything: how can be possible that a 3rd party can resolve an incompatibility that Meta (META not a startup, one of the biggest companies in the world) can't?

Am I doing something wrong then? How can I play my games?

I'm waiting for the LinkCable for tomorrow, it would change something or I just wasted money again?

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?