Showing results for 
Search instead for 
Did you mean: 

Not able to transfer video files on Oculus 2 from PC via USB-C cable

Honored Guest

It seems that I am not able to transfer large or even small vr video files on my Oculus 2. This started approx two weeks ago, after the last updates. When I copy a video file to any folder on my quest the copy window shows, however, at the very end, it closes and the file is not copied.

I uninstalled the drivers, reset my quest, and tried all the tricks in the world, still not working. Also, I noticed that when I connect my Quest 2 to the PC the Quest is not shown on my computer all the time.

Does anyone experience this?

Regrettably, Meta Support did not come back to me on my report for more than a week.




I'm having the same problem but with the quest pro. Files seems to transfer complete but then there's a double beep and the files dont show up. I'm thinking it's a bug in the recent updates

Community Manager
Community Manager

Howdy there, @TraianV! Thank you for bringing this to our attention. We recognize that being unable to transfer your files is interfering with your VR experience. So, we'd like you to be able to report this bug so that our engineers can find a solution as soon as possible. We'll keep the steps here for you to report the bug.


To report a bug from your headset:

  1. Press on your right Touch controller to pull up your universal menu.
  2. Hover over the clock on the left side of the universal menu. When Quick Settings appears, select it to open the Quick Settings panel.
  3. Select Report a Problem.
  4. Follow the instructions to submit your bug report.

To report a bug from the Meta Quest mobile app:

  1. Shake your phone until the Report a Problem screen appears.
  2. Tap Something Isn't Working.
  3. Follow the instructions to submit your bug report.


Already reported this using your method 

So I believe I've found the solution. If your files have a long name then rename them to  one or two words. This has worked for me although not ideal having to change the number of characters 

Community Manager
Community Manager

Thank you for reporting this issue. We would also appreciate it if you could send us a private message so that we can keep helping you.


Please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.

Hi MikeMagnum,

I tried that and it didn't work. Some files had been copied, others not.


@TraianV another thing that you can try is checking the Oculus app settings for the option to enable the "USB option" prompt. Enable it, and next time you plug the headset in, it should ask if you want to use this device as storage go ahead and let it. This might enable you to transfer information over a little smoother. 

Can you try it with a USB C to usb adapter and plug into laptop/PC?. I remember doing this when it worked for me

Hey there, @TraianV! If the recent suggestion that @MikeMagnum mentioned doesn't help, let us know and we'll see if there's anything else we can try out. We'll be looking forward to hearing back from you!