Showing results for 
Search instead for 
Did you mean: 

Nothing loading on my oculus

Honored Guest


my oculus recently started to stop loading anything. When I go to any game it opens for a few seconds then closes. If I try to access explore or store is says please try again later. And when I try to open social it tells me to log in with my Facebook account. When I log in it says I must be logged in to do this. I have restarted my headset and searched the internet for hours attempting things. If anyone has any information please help me. 

thank you


Honored Guest

Having the same issue, hopefully it’s just a server problem since I’ve tried all the solutions I’ve found except for factory resetting and nothing has worked. 

Community Manager
Community Manager

We hate that we missed your post yesterday, but if this is still happening, we definitely want to help each of you get this resolved as quickly as possible.


We'd love if you could reach out to us here, that way we can work with you both one on one, and get to the root of the issue. Thank you for reporting this! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!